falcon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shwetha G S (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (FALCON-106) Falcon compilation fails for hadoop-2 profile
Date Fri, 06 Sep 2013 12:30:51 GMT

    [ https://issues.apache.org/jira/browse/FALCON-106?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13760166#comment-13760166
] 

Shwetha G S edited comment on FALCON-106 at 9/6/13 12:30 PM:
-------------------------------------------------------------

distributed package creation fails:
{noformat}
mvn clean assembly:assembly -P distributed
[INFO] Scanning for projects...
[ERROR] The build could not read 10 projects -> [Help 1]
[ERROR]
[ERROR]   The project org.apache.falcon:falcon-common:0.4-incubating-SNAPSHOT (/work/git/falcon/common/pom.xml)
has 2 errors
[ERROR]     'dependencies.dependency.version' for org.apache.hadoop:hadoop-core:jar must be
a valid version but is '${hadoop.version}'. @ line 49, column 30
[ERROR]     'dependencies.dependency.version' for org.apache.hadoop:hadoop-test:jar must be
a valid version but is '${hadoop.version}'. @ line 55, column 30
[ERROR]
[ERROR]   The project org.apache.falcon:falcon-test-util:0.4-incubating-SNAPSHOT (/work/git/falcon/test-util/pom.xml)
has 2 errors
[ERROR]     'dependencies.dependency.version' for org.apache.hadoop:hadoop-core:jar must be
a valid version but is '${hadoop.version}'. @ line 48, column 30
[ERROR]     'dependencies.dependency.version' for org.apache.hadoop:hadoop-test:jar must be
a valid version but is '${hadoop.version}'. @ line 53, column 30
[ERROR]
[ERROR]   The project org.apache.falcon:falcon-hadoop-dependencies:0.4-incubating-SNAPSHOT
(/work/git/falcon/hadoop-dependencies/pom.xml) has 1 error
[ERROR]     'dependencies.dependency.version' for org.apache.hadoop:hadoop-core:jar must be
a valid version but is '${hadoop.version}'. @ line 47, column 30
[ERROR]
[ERROR]   The project org.apache.falcon:falcon-hadoop-webapp:0.4-incubating-SNAPSHOT (/work/git/falcon/hadoop-webapp/pom.xml)
has 1 error
[ERROR]     'dependencies.dependency.version' for org.apache.hadoop:hadoop-core:jar must be
a valid version but is '${hadoop.version}'. @ line 48, column 30
[ERROR]
[ERROR]   The project org.apache.falcon:falcon-messaging:0.4-incubating-SNAPSHOT (/work/git/falcon/messaging/pom.xml)
has 2 errors
[ERROR]     'dependencies.dependency.version' for org.apache.hadoop:hadoop-core:jar must be
a valid version but is '${hadoop.version}'. @ line 48, column 30
[ERROR]     'dependencies.dependency.version' for org.apache.hadoop:hadoop-test:jar must be
a valid version but is '${hadoop.version}'. @ line 53, column 30
[ERROR]
[ERROR]   The project org.apache.falcon:falcon-process:0.4-incubating-SNAPSHOT (/work/git/falcon/process/pom.xml)
has 1 error
[ERROR]     'dependencies.dependency.version' for org.apache.hadoop:hadoop-core:jar must be
a valid version but is '${hadoop.version}'. @ line 48, column 30
[ERROR]
[ERROR]   The project org.apache.falcon:falcon-oozie-el-extension:0.4-incubating-SNAPSHOT
(/work/git/falcon/oozie-el-extensions/pom.xml) has 1 error
[ERROR]     'dependencies.dependency.version' for org.apache.hadoop:hadoop-core:jar must be
a valid version but is '${hadoop.version}'. @ line 48, column 30
[ERROR]
[ERROR]   The project org.apache.falcon:falcon-oozie-adaptor:0.4-incubating-SNAPSHOT (/work/git/falcon/oozie/pom.xml)
has 1 error
[ERROR]     'dependencies.dependency.version' for org.apache.hadoop:hadoop-core:jar must be
a valid version but is '${hadoop.version}'. @ line 48, column 30
[ERROR]
[ERROR]   The project org.apache.falcon:falcon-replication:0.4-incubating-SNAPSHOT (/work/git/falcon/replication/pom.xml)
has 1 error
[ERROR]     'dependencies.dependency.version' for org.apache.hadoop:hadoop-core:jar must be
a valid version but is '${hadoop.version}'. @ line 48, column 30
[ERROR]
[ERROR]   The project org.apache.falcon:falcon-prism:0.4-incubating-SNAPSHOT (/work/git/falcon/prism/pom.xml)
has 1 error
[ERROR]     'dependencies.dependency.version' for org.apache.hadoop:hadoop-core:jar must be
a valid version but is '${hadoop.version}'. @ line 191, column 30
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following
articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/ProjectBuildingException
{noformat}
                
      was (Author: shwethags):
    distributed package creation fails:

mvn clean assembly:assembly -P distributed
[INFO] Scanning for projects...
[ERROR] The build could not read 10 projects -> [Help 1]
[ERROR]
[ERROR]   The project org.apache.falcon:falcon-common:0.4-incubating-SNAPSHOT (/work/git/falcon/common/pom.xml)
has 2 errors
[ERROR]     'dependencies.dependency.version' for org.apache.hadoop:hadoop-core:jar must be
a valid version but is '${hadoop.version}'. @ line 49, column 30
[ERROR]     'dependencies.dependency.version' for org.apache.hadoop:hadoop-test:jar must be
a valid version but is '${hadoop.version}'. @ line 55, column 30
[ERROR]
[ERROR]   The project org.apache.falcon:falcon-test-util:0.4-incubating-SNAPSHOT (/work/git/falcon/test-util/pom.xml)
has 2 errors
[ERROR]     'dependencies.dependency.version' for org.apache.hadoop:hadoop-core:jar must be
a valid version but is '${hadoop.version}'. @ line 48, column 30
[ERROR]     'dependencies.dependency.version' for org.apache.hadoop:hadoop-test:jar must be
a valid version but is '${hadoop.version}'. @ line 53, column 30
[ERROR]
[ERROR]   The project org.apache.falcon:falcon-hadoop-dependencies:0.4-incubating-SNAPSHOT
(/work/git/falcon/hadoop-dependencies/pom.xml) has 1 error
[ERROR]     'dependencies.dependency.version' for org.apache.hadoop:hadoop-core:jar must be
a valid version but is '${hadoop.version}'. @ line 47, column 30
[ERROR]
[ERROR]   The project org.apache.falcon:falcon-hadoop-webapp:0.4-incubating-SNAPSHOT (/work/git/falcon/hadoop-webapp/pom.xml)
has 1 error
[ERROR]     'dependencies.dependency.version' for org.apache.hadoop:hadoop-core:jar must be
a valid version but is '${hadoop.version}'. @ line 48, column 30
[ERROR]
[ERROR]   The project org.apache.falcon:falcon-messaging:0.4-incubating-SNAPSHOT (/work/git/falcon/messaging/pom.xml)
has 2 errors
[ERROR]     'dependencies.dependency.version' for org.apache.hadoop:hadoop-core:jar must be
a valid version but is '${hadoop.version}'. @ line 48, column 30
[ERROR]     'dependencies.dependency.version' for org.apache.hadoop:hadoop-test:jar must be
a valid version but is '${hadoop.version}'. @ line 53, column 30
[ERROR]
[ERROR]   The project org.apache.falcon:falcon-process:0.4-incubating-SNAPSHOT (/work/git/falcon/process/pom.xml)
has 1 error
[ERROR]     'dependencies.dependency.version' for org.apache.hadoop:hadoop-core:jar must be
a valid version but is '${hadoop.version}'. @ line 48, column 30
[ERROR]
[ERROR]   The project org.apache.falcon:falcon-oozie-el-extension:0.4-incubating-SNAPSHOT
(/work/git/falcon/oozie-el-extensions/pom.xml) has 1 error
[ERROR]     'dependencies.dependency.version' for org.apache.hadoop:hadoop-core:jar must be
a valid version but is '${hadoop.version}'. @ line 48, column 30
[ERROR]
[ERROR]   The project org.apache.falcon:falcon-oozie-adaptor:0.4-incubating-SNAPSHOT (/work/git/falcon/oozie/pom.xml)
has 1 error
[ERROR]     'dependencies.dependency.version' for org.apache.hadoop:hadoop-core:jar must be
a valid version but is '${hadoop.version}'. @ line 48, column 30
[ERROR]
[ERROR]   The project org.apache.falcon:falcon-replication:0.4-incubating-SNAPSHOT (/work/git/falcon/replication/pom.xml)
has 1 error
[ERROR]     'dependencies.dependency.version' for org.apache.hadoop:hadoop-core:jar must be
a valid version but is '${hadoop.version}'. @ line 48, column 30
[ERROR]
[ERROR]   The project org.apache.falcon:falcon-prism:0.4-incubating-SNAPSHOT (/work/git/falcon/prism/pom.xml)
has 1 error
[ERROR]     'dependencies.dependency.version' for org.apache.hadoop:hadoop-core:jar must be
a valid version but is '${hadoop.version}'. @ line 191, column 30
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following
articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/ProjectBuildingException
                  
> Falcon compilation fails for hadoop-2 profile
> ---------------------------------------------
>
>                 Key: FALCON-106
>                 URL: https://issues.apache.org/jira/browse/FALCON-106
>             Project: Falcon
>          Issue Type: Bug
>          Components: build-tools
>            Reporter: Suresh Srinivas
>            Assignee: Suresh Srinivas
>         Attachments: falcon-build-2.x.patch
>
>
> Mainly due to hadoop-core and hadoop-test artifacts not being available in hadoop 2.x.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message