falcon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shwetha G S (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FALCON-223) hive-exec bundles protobuf-2.4.1 which is incompatible with hadoop-2 requiring protobuf-2.5
Date Wed, 24 Sep 2014 06:24:34 GMT

    [ https://issues.apache.org/jira/browse/FALCON-223?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14145972#comment-14145972
] 

Shwetha G S commented on FALCON-223:
------------------------------------

This jira added hadoop classpath before falcon classpath. But this will create issues if falcon
depends on a particular version of jar, hadoop has different version. Falcon fails are runtime.
We should revert this. [~svenkat], do you see any issues?

> hive-exec bundles protobuf-2.4.1 which is incompatible with hadoop-2 requiring protobuf-2.5
> -------------------------------------------------------------------------------------------
>
>                 Key: FALCON-223
>                 URL: https://issues.apache.org/jira/browse/FALCON-223
>             Project: Falcon
>          Issue Type: Bug
>    Affects Versions: 0.4
>            Reporter: Venkatesh Seetharam
>            Assignee: Arpit Gupta
>            Priority: Blocker
>             Fix For: 0.4
>
>         Attachments: FALCON-223.v1.patch
>
>
> This is not an issue with hadoop-1 but only hadoop-2.
> This is fixed in hive-0.13 (HIVE-5112) but its not released yet for us to upgrade. A
quick fix is to change the falcon startup scripts to set the hadoop classpath prior to falcon
dependencies.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message