falcon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mahak Mukhi <mmu...@yahoo-inc.com.INVALID>
Subject Re: Configurational changes not getting relflected after build
Date Mon, 23 Feb 2015 16:53:36 GMT
Hi,
So, I am trying to replication between hcat servers. I've been successful in one direction,
i.e. say from server A to server B, but when I try to do the same in the reverse direction,
i.e. server B to server A, the job fails and the oozie server gives following exception: 
action: pre-process failed 
error message: java.lang.NoClassDefFoundError: org/apache/hadoop/hive/conf/HiveConf
So I resorted to update the pre-process.xml to include the following property: 
 <property>
                <name>oozie.launcher.oozie.action.sharelib.for.hive</name>
                <value>hcat_current,hive_current</value>
  </property>
and rebuilt falcon and redeployed it, but for some reason these changes are not getting reflected.
I had faced a similar error when trying to do replication from server A to server B, but there
the job failed in table-export phase with same error so I had updated table-export.xml with
similar property and it worked. 

But now even when I try and change something in table-export.xml, it does not get reflected
in the oozie job workflows. I even checked the newly deployed falcon to see if those files
are updated in there and they are, yet the oozie jobs show obsolete configs.So I am wondering
if falcon stores these template files somewhere on oozie and is getting obsolete values from
there instead.
Also, I changed uri:oozie:workflow:0.3 to uri:oozie:workflow:0.4 in all these template files.
Regards,Mahak Mukhi 

     On Monday, February 23, 2015 10:41 AM, Srikanth Sundarrajan <sriksun@hotmail.com>
wrote:
   

 Hi Mukhi,
    pre-process.xml is an internal template that falcon uses for orchestration and is not
available to user extension of capabilities. If you can share the exact use case that you
are wanting to solve and what issues you are running into, one of us can attempt to solve
if possible.

Regards
Srikanth Sundarrajan

> Date: Mon, 23 Feb 2015 16:37:02 +0000
> From: mmukhi@yahoo-inc.com.INVALID
> To: sshivalingamurthy@hortonworks.com
> CC: agresch@yahoo-inc.com; dev@falcon.apache.org
> Subject: Re: Configurational changes not getting relflected after build
> 
> Hi,
> I tried updating the property but that doesn't work either; it's not getting reflected
in the job workflow.Does falcon store these template files somewhere on oozie server and could
it be reading those obsolete files instead?
> p.s. I am updating the pre-process.xml because the oozie jobs fail in that action with
following exception: java.lang.NoClassDefFoundError: org/apache/hadoop/hive/conf/HiveConfI
had earlier rectified this error by updating table-export.xmla and table-import.xml, when
those were the actions where the job failed.
> 
> Regards,Mahak Mukhi
>  
> 
>      On Sunday, February 22, 2015 11:14 PM, Shwetha Shivalingamurthy <sshivalingamurthy@hortonworks.com>
wrote:
>    
> 
>  What are you trying to do? Why did you change pre-process.xml?
> 
> -Shwetha
> 
> 
> On 21/02/15 2:13 am, "Mahak Mukhi" <mmukhi@yahoo-inc.com.INVALID> wrote:
> 
> >Hi,
> >I made following changes in this file
> >oozie/src/main/resources/action/pre-process.xml
> >1. changed oozie:workflow:0.3 to oozie:workflow:0.4
> > 2. added this property
> >          <property>
> >                <name>oozie.action.sharelib.for.hive</name>
> >                <value>hcat_current,hive_current</value>
> >            </property>
> > But when I build it and submit feeds these changes aren't reflected in
> >the oozie workflow. The job definition doesn't contain this newly added
> >property neither is the new workflow version reflected. I looked up the
> >jar(falcon-oozie-adaptor-0.7-SNAPSHOT.jar) in the deployed instance and
> >the pre-process.xml in there shows the changes that I made, so I can be
> >certain the deployment is valid. I even restarted the oozie server but to
> >no success. 
> >
> >Need help figuring out how this oozie workflow is not getting updated.
> >
> >Regards,Mahak Mukhi
> > 
> 
> 
>    
                         

   
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message