flex-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Maurice Amsellem (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLEX-33860) Need Support For iOS7
Date Mon, 04 Nov 2013 13:37:19 GMT

    [ https://issues.apache.org/jira/browse/FLEX-33860?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13812831#comment-13812831
] 

Maurice Amsellem commented on FLEX-33860:
-----------------------------------------

Thank you Keith, that's pretty much what I had in mind (see post on dev@flex.apache.org).
This would be extended to  spark Application container as well (not needed for TabbedNavigatorApplicationSkin).
I also had similar code to detect IOS7. The only issue is it won't work with ADL, but only
on device. :-(.

I will work to put that in the SDK as soon as I get some time.

FYI, There is also another approach:  introduce a new "os-version" selector in @media css,
so that you don't hard code skins in the the code.
that's much more flexible, but also much more difficult to implement.
This second approach got some interest from the Flex team, so I will also spend time on it.

Wish me good luck :-)


> Need Support For iOS7
> ---------------------
>
>                 Key: FLEX-33860
>                 URL: https://issues.apache.org/jira/browse/FLEX-33860
>             Project: Apache Flex
>          Issue Type: Bug
>          Components: Mobile: ActionBar
>    Affects Versions: Apache Flex 4.11.0
>         Environment: iOS 7
>            Reporter: Keith Lee
>            Assignee: Maurice Amsellem
>
> iOS 7 now runs everything in full screen, with the status bar being transparent, so mobile
Flex applications now need a 20px padding at the top in order for action bar text to not be
obscured by the status bar text and symbols.



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message