flex-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Harui (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLEX-34540) Error installing Apache Flex versions 4.9.1, 4.10, 4.12 or 4.12.1 using installer
Date Tue, 07 Oct 2014 22:35:34 GMT

    [ https://issues.apache.org/jira/browse/FLEX-34540?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14162701#comment-14162701
] 

Alex Harui commented on FLEX-34540:
-----------------------------------

I posted all of the Adobe-owned external dependencies on source forge in the Flex SDK project.

I changed the following files on the flex.a.o website:

1) installer/flex-sdk-installer-config-4.0.xml: The 4.12.x builds now have "legacy=true" so
they will use the same code paths as 4.11 and earlier and not the ant_on_air code.  I then
changed the URLs for afe.jar and the other font jars, flex-messaging-common.jar, and osmf.jar
to point to flex.apache.org.
2) I added redirects in our .htaccess file from flex.apache.org to the files on source forge.
 This was required because the true URL requires a URL parameter and that would mess up the
old code paths in the installer.  By first hitting a URL without URL params, the installer
picks up the right name of the file, then the redirect goes and gets the right file on SourceForge.

The redirects break the progress bar showing correct progress, and I've only tested 4.12.1,
but appears to bring down the right files and set up the config files correctly.

> Error installing Apache Flex versions 4.9.1, 4.10, 4.12 or 4.12.1 using installer
> ---------------------------------------------------------------------------------
>
>                 Key: FLEX-34540
>                 URL: https://issues.apache.org/jira/browse/FLEX-34540
>             Project: Apache Flex
>          Issue Type: Bug
>          Components: InstallApacheFlex, Installer
>    Affects Versions: Install Apache Flex 3.1
>            Reporter: Justin Mclean
>            Priority: Critical
>
> The changes to Adobe SVN (it now requires a user name and password) have broken installs
for early versions of Apache Flex.  A name password box pops up when trying to install any
version of the Flex SDK less than 4.13.0 when trying to download OSMF. OSMF is not an optional
component.
> This effects versions 4.9, 4.10, 4,12 and 4.12.1 fail to instal. 4.11 and 4.13 work.
For versions  4.12/4.12.1 the config files are not correctly updated giving the user a broken
SDK.
> For 4.9/4.10 the Cancel button is pressed the last step is shown as in error and the
log contains:
> Downloading osmf.swc from: http://opensource.adobe.com/svn/opensource/flex/sdk/branches/4.y/frameworks/libs/
> Unable to download OSMF_SWC
> Installation complete.
> For 4.13 several last steps are in error and this shows in the log.
> Downloading OSMF.swc from: http://downloads.sourceforge.net/project/osmf.adobe/OSMF%202.0%20Release%20%28final%20source%2C%20ASDocs%2C%20pdf%20guides%20and%20release%20notes%29
> Downloading afe.jar from: http://opensource.adobe.com/svn/opensource/flex/sdk/branches/4.y/lib
>       [get] [IOErrorEvent type="ioError" bubbles=false cancelable=false eventPhase=2
text="Error #2032" errorID=2032]



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message