flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fabian Hueske (JIRA)" <j...@apache.org>
Subject [jira] [Created] (FLINK-1079) Inconsistent parameter naming in MapPartitionFunction
Date Mon, 01 Sep 2014 07:46:21 GMT
Fabian Hueske created FLINK-1079:

             Summary: Inconsistent parameter naming in MapPartitionFunction
                 Key: FLINK-1079
                 URL: https://issues.apache.org/jira/browse/FLINK-1079
             Project: Flink
          Issue Type: Improvement
          Components: Local Runtime
    Affects Versions: 0.6-incubating
            Reporter: Fabian Hueske
            Priority: Trivial

The input parameter of the {{MapPartitionFunction}} is called {{records}} which is different
from the naming in the previous functions ({{GroupReduceFunction}}, {{FlatCombineFunction}})
which name the Iterable {{values}}.

I propose to rename the parameter in {{MapPartitionFunction}} to {{values}} for consistency

This message was sent by Atlassian JIRA

View raw message