flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stephan Ewen (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLINK-1079) Inconsistent parameter naming in MapPartitionFunction
Date Mon, 01 Sep 2014 16:54:20 GMT

    [ https://issues.apache.org/jira/browse/FLINK-1079?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14117553#comment-14117553
] 

Stephan Ewen commented on FLINK-1079:
-------------------------------------

I'll make a quick fix for this...

> Inconsistent parameter naming in MapPartitionFunction
> -----------------------------------------------------
>
>                 Key: FLINK-1079
>                 URL: https://issues.apache.org/jira/browse/FLINK-1079
>             Project: Flink
>          Issue Type: Improvement
>          Components: Local Runtime
>    Affects Versions: 0.6-incubating
>            Reporter: Fabian Hueske
>            Priority: Trivial
>              Labels: starter
>
> The input parameter of the {{MapPartitionFunction}} is called {{records}} which is different
from the naming in the previous functions ({{GroupReduceFunction}}, {{FlatCombineFunction}})
which name the Iterable {{values}}.
> I propose to rename the parameter in {{MapPartitionFunction}} to {{values}} for consistency
reasons.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message