flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stephan Ewen (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (FLINK-1079) Inconsistent parameter naming in MapPartitionFunction
Date Mon, 01 Sep 2014 17:58:21 GMT

     [ https://issues.apache.org/jira/browse/FLINK-1079?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Stephan Ewen resolved FLINK-1079.
---------------------------------
       Resolution: Fixed
    Fix Version/s: 0.7-incubating
         Assignee: Stephan Ewen

Fixed via fbed013db60d7c45dcd11b6303ffa16220557e13

> Inconsistent parameter naming in MapPartitionFunction
> -----------------------------------------------------
>
>                 Key: FLINK-1079
>                 URL: https://issues.apache.org/jira/browse/FLINK-1079
>             Project: Flink
>          Issue Type: Improvement
>          Components: Local Runtime
>    Affects Versions: 0.6-incubating
>            Reporter: Fabian Hueske
>            Assignee: Stephan Ewen
>            Priority: Trivial
>              Labels: starter
>             Fix For: 0.7-incubating
>
>
> The input parameter of the {{MapPartitionFunction}} is called {{records}} which is different
from the naming in the previous functions ({{GroupReduceFunction}}, {{FlatCombineFunction}})
which name the Iterable {{values}}.
> I propose to rename the parameter in {{MapPartitionFunction}} to {{values}} for consistency
reasons.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message