flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From danielblazevski <...@git.apache.org>
Subject [GitHub] flink pull request: Flink 1745
Date Sat, 03 Oct 2015 22:48:45 GMT
Github user danielblazevski commented on the pull request:

    https://github.com/apache/flink/pull/1220#issuecomment-145295999
  
    When looking at the details of the Travis CI build, I found the first error messages to
be:
    -------------------------------------------------------------------------  Begin of error
    [ERROR] /home/travis/build/apache/flink/flink-staging/flink-ml/src/main/scala/org/apache/flink/ml/nn/KNN.scala:23:
error: object DataSetUtils is not a member of package org.apache.flink.api.scala
    
    [INFO] import org.apache.flink.api.scala.DataSetUtils._
    
    [INFO]                                   ^
    
    [ERROR] /home/travis/build/apache/flink/flink-staging/flink-ml/src/main/scala/org/apache/flink/ml/nn/KNN.scala:170:
error: value zipWithUniqueId is not a member of org.apache.flink.api.scala.DataSet[T]
    
    --------------------------------------------------------------------------------------
end of errors
    
    There are additional errors that follow, but those are the first two errors that popped
up.  The import of DataSetUtils._ was adopted from @chiwanpark, maybe he has an idea of what
is the cause of the error.   I unfortunately was not using Travis CI from the start, but will
try to use it from now on.


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at infrastructure@apache.org or file a JIRA ticket
with INFRA.
---

Mime
View raw message