flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLINK-2479) Refactoring of org.apache.flink.runtime.operators.testutils.TestData class
Date Tue, 06 Oct 2015 15:51:26 GMT

    [ https://issues.apache.org/jira/browse/FLINK-2479?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14945231#comment-14945231

ASF GitHub Bot commented on FLINK-2479:

Github user fhueske commented on the pull request:

    Hi @zentol, thanks for this effort!
    I found a few classes that could be renamed as well. Otherwise, the PR looks good.

> Refactoring of org.apache.flink.runtime.operators.testutils.TestData class
> --------------------------------------------------------------------------
>                 Key: FLINK-2479
>                 URL: https://issues.apache.org/jira/browse/FLINK-2479
>             Project: Flink
>          Issue Type: Task
>          Components: Local Runtime
>            Reporter: Ricky Pogalz
>            Assignee: Chesnay Schepler
>            Priority: Minor
>             Fix For: pre-apache
> Currently, there are still tests which use {{Record}} from the old record API. One of
the test util classes is {{TestData}}, including {{Generator}} and some other classes still
using {{Record}}. An alternative implementation of the {{Generator}} without {{Record}} already
exists in the {{TestData}} class, namely {{TupleGenerator}}.
> Please replace the utility classes in {{TestData}} that still use {{Record}} and adapt
all of its usages.

This message was sent by Atlassian JIRA

View raw message