flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stephan Ewen (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLINK-3009) Cannot build docs with Jekyll 3.0.0
Date Mon, 16 Nov 2015 21:54:10 GMT

    [ https://issues.apache.org/jira/browse/FLINK-3009?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15007410#comment-15007410
] 

Stephan Ewen commented on FLINK-3009:
-------------------------------------

I think that would actually be very nice!

If you would contribute that part, we could upload it to the project web site, or simply link
to your repository, if that is okay (would need a permanent git tag then).

> Cannot build docs with Jekyll 3.0.0
> -----------------------------------
>
>                 Key: FLINK-3009
>                 URL: https://issues.apache.org/jira/browse/FLINK-3009
>             Project: Flink
>          Issue Type: Bug
>          Components: Build System
>    Affects Versions: 0.10.0
>            Reporter: Ufuk Celebi
>            Priority: Minor
>
> Building the docs with the newly released Jekyll 3.0.0 fails:
> {code}
> Configuration file: /Users/ufuk/code/flink/docs/_config.yml
> /Users/ufuk/code/flink/docs/_plugins/removeDuplicateLicenseHeaders.rb:63:in `<module:Jekyll>':
cannot load such file -- jekyll/post (LoadError)
> 	from /Users/ufuk/code/flink/docs/_plugins/removeDuplicateLicenseHeaders.rb:25:in `<top
(required)>'
> 	from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:126:in
`require'
> 	from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:126:in
`require'
> 	from /Library/Ruby/Gems/2.0.0/gems/jekyll-3.0.0/lib/jekyll/plugin_manager.rb:75:in `block
(2 levels) in require_plugin_files'
> 	from /Library/Ruby/Gems/2.0.0/gems/jekyll-3.0.0/lib/jekyll/plugin_manager.rb:74:in `each'
> 	from /Library/Ruby/Gems/2.0.0/gems/jekyll-3.0.0/lib/jekyll/plugin_manager.rb:74:in `block
in require_plugin_files'
> 	from /Library/Ruby/Gems/2.0.0/gems/jekyll-3.0.0/lib/jekyll/plugin_manager.rb:73:in `each'
> 	from /Library/Ruby/Gems/2.0.0/gems/jekyll-3.0.0/lib/jekyll/plugin_manager.rb:73:in `require_plugin_files'
> 	from /Library/Ruby/Gems/2.0.0/gems/jekyll-3.0.0/lib/jekyll/plugin_manager.rb:18:in `conscientious_require'
> 	from /Library/Ruby/Gems/2.0.0/gems/jekyll-3.0.0/lib/jekyll/site.rb:97:in `setup'
> 	from /Library/Ruby/Gems/2.0.0/gems/jekyll-3.0.0/lib/jekyll/site.rb:49:in `initialize'
> 	from /Library/Ruby/Gems/2.0.0/gems/jekyll-3.0.0/lib/jekyll/commands/build.rb:30:in `new'
> 	from /Library/Ruby/Gems/2.0.0/gems/jekyll-3.0.0/lib/jekyll/commands/build.rb:30:in `process'
> 	from /Library/Ruby/Gems/2.0.0/gems/jekyll-3.0.0/lib/jekyll/commands/build.rb:18:in `block
(2 levels) in init_with_program'
> 	from /Library/Ruby/Gems/2.0.0/gems/mercenary-0.3.5/lib/mercenary/command.rb:220:in `call'
> 	from /Library/Ruby/Gems/2.0.0/gems/mercenary-0.3.5/lib/mercenary/command.rb:220:in `block
in execute'
> 	from /Library/Ruby/Gems/2.0.0/gems/mercenary-0.3.5/lib/mercenary/command.rb:220:in `each'
> 	from /Library/Ruby/Gems/2.0.0/gems/mercenary-0.3.5/lib/mercenary/command.rb:220:in `execute'
> 	from /Library/Ruby/Gems/2.0.0/gems/mercenary-0.3.5/lib/mercenary/program.rb:42:in `go'
> 	from /Library/Ruby/Gems/2.0.0/gems/mercenary-0.3.5/lib/mercenary.rb:19:in `program'
> 	from /Library/Ruby/Gems/2.0.0/gems/jekyll-3.0.0/bin/jekyll:17:in `<top (required)>'
> 	from /usr/local/bin/jekyll:23:in `load'
> 	from /usr/local/bin/jekyll:23:in `<main>'
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message