flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Metzger (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLINK-4170) Remove `CONFIG_` prefix from KinesisConfigConstants variables
Date Thu, 07 Jul 2016 13:26:11 GMT

    [ https://issues.apache.org/jira/browse/FLINK-4170?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15366086#comment-15366086
] 

Robert Metzger commented on FLINK-4170:
---------------------------------------

+1

> Remove `CONFIG_` prefix from KinesisConfigConstants variables
> -------------------------------------------------------------
>
>                 Key: FLINK-4170
>                 URL: https://issues.apache.org/jira/browse/FLINK-4170
>             Project: Flink
>          Issue Type: Improvement
>          Components: Streaming Connectors
>            Reporter: Ufuk Celebi
>             Fix For: 1.1.0
>
>
> I find the static variable names verbose. I think it's clear from context that they refer
to the Kinesis configuration since they are all gathered in that class.
> Therefore would like to remove the {{CONFIG_}} prefix before the release, so that we
have
> {code}
> conf.put(KinesisConfigConstants.AWS_REGION, "")
> {code}
> instead of 
> {code}
> conf.put(KinesisConfigConstants.CONFIG_AWS_REGION, "")
> {code}
> For longer variables it becomes even longer otherwise.
> ---
> Some basic variable names that might be accessed frequently are also very long:
> {code}
> CONFIG_AWS_CREDENTIALS_PROVIDER_BASIC_SECRETKEY
> CONFIG_AWS_CREDENTIALS_PROVIDER_BASIC_ACCESSKEYID
> {code}
> It might suffice to just have:
> {code}
> AWS_SECRET_KEY
> AWS_ACCESS_KEY
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message