flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chesnay Schepler (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLINK-4243) Change "Scope" to "Namespace" for Metrics
Date Wed, 27 Jul 2016 11:19:20 GMT

    [ https://issues.apache.org/jira/browse/FLINK-4243?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15395470#comment-15395470
] 

Chesnay Schepler commented on FLINK-4243:
-----------------------------------------

I just realized that this would be a API breaking change. We expose a few methods that contain
"Scope" in their name, which we would have to change as well (otherwise we would just be inconsistent).

With that in mind I'm leaning against using "namespace".

> Change "Scope" to "Namespace" for Metrics
> -----------------------------------------
>
>                 Key: FLINK-4243
>                 URL: https://issues.apache.org/jira/browse/FLINK-4243
>             Project: Flink
>          Issue Type: Improvement
>          Components: Metrics
>    Affects Versions: 1.1.0
>            Reporter: Stephan Ewen
>
> It seems that using **"namespace"** for the names (dotted concatenation) of metric groups
is more common than **"scope"**.
> I suggest to follow that terminology in Flink.
> [~jgrier] and [~Zentol], I would be interested in what you think there.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message