flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Metzger (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (FLINK-4676) Merge flink-batch-connectors and flink-streaming-connectors modules
Date Mon, 26 Sep 2016 12:23:20 GMT

     [ https://issues.apache.org/jira/browse/FLINK-4676?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Robert Metzger updated FLINK-4676:
    Component/s: Streaming Connectors
                 Batch Connectors and Input/Output Formats

> Merge flink-batch-connectors and flink-streaming-connectors modules
> -------------------------------------------------------------------
>                 Key: FLINK-4676
>                 URL: https://issues.apache.org/jira/browse/FLINK-4676
>             Project: Flink
>          Issue Type: Task
>          Components: Batch Connectors and Input/Output Formats, Build System, Streaming
>    Affects Versions: 1.2.0
>            Reporter: Fabian Hueske
>            Priority: Minor
>             Fix For: 1.2.0
> We have two separate Maven modules for batch and streaming connectors (flink-batch-connectors
and flink-streaming-connectors) that contain modules for the individual external systems and
storage formats such as HBase, Cassandra, Avro, Elasticsearch, etc.
> Some of these systems can be used in streaming as well as batch jobs as for instance
HBase, Cassandra, and Elasticsearch. 
> However, due to the separate main modules for streaming and batch connectors, we currently
need to decide where to put a connector. 
> For example, the flink-connector-cassandra module is located in flink-streaming-connectors
but includes a CassandraInputFormat and CassandraOutputFormat (i.e., a batch source and sink).
> This issue is about merging flink-batch-connectors and flink-streaming-connectors into
a joint flink-connectors module.
> Names of moved modules should not be changed (although this leads to an inconsistent
naming scheme: flink-connector-cassandra vs. flink-hbase) to keep the change of code structure
transparent to users. 

This message was sent by Atlassian JIRA

View raw message