flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fabian Hueske (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLINK-1890) Add note to docs that ReadFields annotations are currently not evaluated
Date Thu, 13 Oct 2016 18:41:20 GMT

    [ https://issues.apache.org/jira/browse/FLINK-1890?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15572810#comment-15572810
] 

Fabian Hueske commented on FLINK-1890:
--------------------------------------

I'd keep the issue open. I'll add the starter tag to it. Maybe somebody picks it up.

> Add note to docs that ReadFields annotations are currently not evaluated
> ------------------------------------------------------------------------
>
>                 Key: FLINK-1890
>                 URL: https://issues.apache.org/jira/browse/FLINK-1890
>             Project: Flink
>          Issue Type: Wish
>          Components: DataSet API
>            Reporter: Stefan Bunk
>            Priority: Minor
>              Labels: starter
>
> In the Scala API, you have the option to declare forwarded fields via the
> {{withForwardedFields}} method.
> It would be nice to have sth. similar for read fields, as otherwise one needs to create
a class, which I personally try to avoid for readability.
> Maybe grouping all annotations in one function and have a first parameter indicating
the type of annotation is also an option, if you plan on adding more annotations and want
to keep the interface smaller.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message