flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLINK-3999) Rename the `running` flag in the drivers to `canceled`
Date Tue, 18 Oct 2016 21:19:58 GMT

    [ https://issues.apache.org/jira/browse/FLINK-3999?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15586694#comment-15586694

ASF GitHub Bot commented on FLINK-3999:

Github user nssalian commented on the issue:

    @StephanEwen ,thanks for that, that makes sense. But it is hard for someone new to understand
the problem you mention. If someone familiar with the product, could review new JIRAs for
clear benefit / validity, that would encourage folks jumping on the tasks to know it better.
I realize it may not be feasible but it saves time too to let them know in advance. I can
certainly close the PR and make it Not a Problem. But if there is a better way to have this
clearer , I would appreciate it before the effort is put in. 

> Rename the `running` flag in the drivers to `canceled`
> ------------------------------------------------------
>                 Key: FLINK-3999
>                 URL: https://issues.apache.org/jira/browse/FLINK-3999
>             Project: Flink
>          Issue Type: Bug
>          Components: Local Runtime
>            Reporter: Gabor Gevay
>            Assignee: Neelesh Srinivas Salian
>            Priority: Trivial
> The name of the {{running}} flag in the drivers doesn't reflect its usage: when the operator
just stops normally, then it is not running anymore, but the {{running}}  flag will still
be true, since the {{running}} flag is only set when cancelling.
> It should be renamed, and the value inverted.

This message was sent by Atlassian JIRA

View raw message