flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLINK-3999) Rename the `running` flag in the drivers to `canceled`
Date Wed, 19 Oct 2016 14:59:58 GMT

    [ https://issues.apache.org/jira/browse/FLINK-3999?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15588991#comment-15588991

ASF GitHub Bot commented on FLINK-3999:

Github user nssalian commented on the issue:

    Thanks @uce, agreed, it would be a community effort indeed. I will try to help as much
as possible.
     @ggevay, it's alright. I'll close the PR. 

> Rename the `running` flag in the drivers to `canceled`
> ------------------------------------------------------
>                 Key: FLINK-3999
>                 URL: https://issues.apache.org/jira/browse/FLINK-3999
>             Project: Flink
>          Issue Type: Bug
>          Components: Local Runtime
>            Reporter: Gabor Gevay
>            Assignee: Neelesh Srinivas Salian
>            Priority: Trivial
> The name of the {{running}} flag in the drivers doesn't reflect its usage: when the operator
just stops normally, then it is not running anymore, but the {{running}}  flag will still
be true, since the {{running}} flag is only set when cancelling.
> It should be renamed, and the value inverted.

This message was sent by Atlassian JIRA

View raw message