flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jens Kat (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (FLINK-5005) Publish Scala 2.12 artifacts
Date Wed, 04 Jan 2017 11:46:58 GMT

    [ https://issues.apache.org/jira/browse/FLINK-5005?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15798029#comment-15798029
] 

Jens Kat edited comment on FLINK-5005 at 1/4/17 11:46 AM:
----------------------------------------------------------

I did some initial research, besides all changes that are needed for coding it seems the following
dependencies are a blocker (because they don't exist yet for 2.12):
* com.data-artisans
** flakka-actor_${scala.binary.version}
** flakka-remote_${scala.binary.version}
** flakka-slf4j_${scala.binary.version}
** flakka-testkit_${scala.binary.version}
** flakka-camel_${scala.binary.version}
* org.scalanlp.breeze_${scala.binary.version}
* org.scalamacros.quasiquotes_${scala.binary.version} (but this one is only used in the scala-2.10
profile, so not an issue)

The following dependencies exist for 2.12 but only for a higher version number:
- com.twitter.chill_${scala.binary.version}: 0.8.1 => 0.9.0
- org.scalatest.scalatest_${scala.binary.version}: 2.2.2 => 3.0.1
- com.github.scopt.scopt_${scala.binary.version}: 3.2.0 => 3.5.0
- org.clapper.grizzled-slf4j_${scala.binary.version}: 1.1.1 => 1.3.0
- org.apache.kafka.kafka_${scala.binary.version}: 0.8.2.2, 0.9.0.1 => 0.10.1.1




was (Author: jenskat):
I did some initial research, besides all changes that are needed for coding it seems the following
dependencies are a blocker (because they don't exist yet for 2.12):
- com.data-artisans
  - flakka-actor_${scala.binary.version}
  - flakka-remote_${scala.binary.version}
  - flakka-slf4j_${scala.binary.version}
  - flakka-testkit_${scala.binary.version}
  - flakka-camel_${scala.binary.version}
- org.scalanlp.breeze_${scala.binary.version}
- org.scalamacros.quasiquotes_${scala.binary.version} (but this one is only used in the scala-2.10
profile, so not an issue)

The following dependencies exist for 2.12 but only for a higher version number:
- com.twitter.chill_${scala.binary.version}: 0.8.1 => 0.9.0
- org.scalatest.scalatest_${scala.binary.version}: 2.2.2 => 3.0.1
- com.github.scopt.scopt_${scala.binary.version}: 3.2.0 => 3.5.0
- org.clapper.grizzled-slf4j_${scala.binary.version}: 1.1.1 => 1.3.0
- org.apache.kafka.kafka_${scala.binary.version}: 0.8.2.2, 0.9.0.1 => 0.10.1.1



> Publish Scala 2.12 artifacts
> ----------------------------
>
>                 Key: FLINK-5005
>                 URL: https://issues.apache.org/jira/browse/FLINK-5005
>             Project: Flink
>          Issue Type: Improvement
>            Reporter: Andrew Roberts
>
> Scala 2.12 was [released|http://www.scala-lang.org/news/2.12.0] today, and offers many
compile-time and runtime speed improvements. It would be great to get artifacts up on maven
central to allow Flink users to migrate to Scala 2.12.0.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message