flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "mingleizhang (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (FLINK-7114) Remove the hardcoded way like classpath is written by a string
Date Fri, 07 Jul 2017 00:55:00 GMT

    [ https://issues.apache.org/jira/browse/FLINK-7114?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16077427#comment-16077427
] 

mingleizhang edited comment on FLINK-7114 at 7/7/17 12:54 AM:
--------------------------------------------------------------

This is not only the problem of hadoop version, but this kinda hardcoded is not really a very
good way. And I will refine it to {{DistributedFileSystem.class.getName}} for getting its
classpath to a more flexable way. Similarly, I believe change all this kind code in this JIRA
is not good I believe. So, I would create subtask for every module if there is no problem.



was (Author: mingleizhang):
This is not only the problem of hadoop version, but this kinda hardcoded way is not really
a very good way. And I will refine it to {{DistributedFileSystem.class.getName}} for getting
its classpath to a more flexable way. Similarly, I believe change all this kind code in this
JIRA is not good I believe. So, I would create subtask for every module if there is no problem.


> Remove the hardcoded way like classpath is written by a string
> --------------------------------------------------------------
>
>                 Key: FLINK-7114
>                 URL: https://issues.apache.org/jira/browse/FLINK-7114
>             Project: Flink
>          Issue Type: Bug
>          Components: Local Runtime
>            Reporter: mingleizhang
>            Assignee: mingleizhang
>
> For example, Like in {{HadoopFileSystem}}  class, there is a field which is written like
{{private static final String DEFAULT_HDFS_CLASS = "org.apache.hadoop.hdfs.DistributedFileSystem";}}.
This way of writing has a bad stuff, once the classpath changes, it is difficult to find the
error. I suggest we should change it to a more flexable way.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message