flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Till Rohrmann (JIRA)" <j...@apache.org>
Subject [jira] [Assigned] (FLINK-5851) Renaming AsyncCollector into ResultPromise/ResultFuture
Date Tue, 22 Aug 2017 13:07:03 GMT

     [ https://issues.apache.org/jira/browse/FLINK-5851?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Till Rohrmann reassigned FLINK-5851:
------------------------------------

    Assignee: mingleizhang

> Renaming AsyncCollector into ResultPromise/ResultFuture
> -------------------------------------------------------
>
>                 Key: FLINK-5851
>                 URL: https://issues.apache.org/jira/browse/FLINK-5851
>             Project: Flink
>          Issue Type: Improvement
>          Components: DataStream API
>    Affects Versions: 1.2.0, 1.3.0
>            Reporter: Till Rohrmann
>            Assignee: mingleizhang
>             Fix For: 1.4.0
>
>
> Currently, the async I/O API gives an {{AsyncCollector}} to an {{AsyncFunction}} implementation.
The name does not really reflect what the {{AsyncCollector}} does since it does not collect
but is actually a one time completable future. Therefore, I propose to rename the {{AsyncCollector}}
into {{ResultPromise}} or {{ResultFuture}}. This is API changing.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message