flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jameslafa <...@git.apache.org>
Subject [GitHub] flink pull request #4648: [FLINK-7584] [doc] Fix checkstyle version in Setup...
Date Tue, 05 Sep 2017 14:55:43 GMT
GitHub user jameslafa opened a pull request:

    https://github.com/apache/flink/pull/4648

    [FLINK-7584] [doc] Fix checkstyle version in Setup IDE

    ## Problem
    There is a breaking change in the Checkstyle-IDEA plugin since version **8.1**. The Flink
`checkstyle.xml` is working up to version **8.0**.
    
    ## Fix
    Changing the `checkstyle.xml` is a sensible topic so we decided to updated the documentation
to stipulate that we have to use the **8.0** version instead of **8.1+**.


You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/jameslafa/flink 7584-update-documentation-setup-ide

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/flink/pull/4648.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #4648
    
----
commit 434e52089f65cfb4784e326b661ba80dfb1bb9a1
Author: James Lafa <james@data-artisans.com>
Date:   2017-09-05T14:49:46Z

    [FLINK-7584] [doc] Fix checkstyle version in Setup IDE

----


---

Mime
View raw message