flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLINK-4034) Dependency convergence on com.101tec:zkclient and com.esotericsoftware.kryo:kryo
Date Wed, 31 Jan 2018 13:28:00 GMT

    [ https://issues.apache.org/jira/browse/FLINK-4034?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16346815#comment-16346815
] 

ASF GitHub Bot commented on FLINK-4034:
---------------------------------------

Github user asfgit closed the pull request at:

    https://github.com/apache/flink/pull/2192


> Dependency convergence on com.101tec:zkclient and com.esotericsoftware.kryo:kryo
> --------------------------------------------------------------------------------
>
>                 Key: FLINK-4034
>                 URL: https://issues.apache.org/jira/browse/FLINK-4034
>             Project: Flink
>          Issue Type: Bug
>          Components: Build System
>    Affects Versions: 1.0.3
>            Reporter: Vladislav Pernin
>            Priority: Major
>
> If dependency convergence is enabled and asserted on Maven, projects using Flink do not
compile.
> Example :
> {code}
> Dependency convergence error for com.esotericsoftware.kryo:kryo:2.24.0 paths to dependency
are:
> +-groupidXXX:artifactidXXX:versionXXX
>   +-org.apache.flink:flink-java:1.0.3
>     +-org.apache.flink:flink-core:1.0.3
>       +-com.esotericsoftware.kryo:kryo:2.24.0
> and
> +-groupidXXX:artifactidXXX:versionXXX
>   +-org.apache.flink:flink-streaming-java_2.11:1.0.3
>     +-org.apache.flink:flink-runtime_2.11:1.0.3
>       +-com.twitter:chill_2.11:0.7.4
>         +-com.twitter:chill-java:0.7.4
>           +-com.esotericsoftware.kryo:kryo:2.21
> and
> +-groupidXXX:artifactidXXX:versionXXX
>   +-org.apache.flink:flink-streaming-java_2.11:1.0.3
>     +-org.apache.flink:flink-runtime_2.11:1.0.3
>       +-com.twitter:chill_2.11:0.7.4
>         +-com.esotericsoftware.kryo:kryo:2.21
> {code}		
> 		
> {code}
> Dependency convergence error for com.101tec:zkclient:0.7 paths to dependency are:
> +-groupidXXX:artifactidXXX:versionXXX
>   +-org.apache.flink:flink-connector-kafka-0.8_2.11:1.0.3
>     +-org.apache.flink:flink-connector-kafka-base_2.11:1.0.3
>       +-com.101tec:zkclient:0.7
> and
> +-groupidXXX:artifactidXXX:versionXXX
>   +-org.apache.flink:flink-connector-kafka-0.8_2.11:1.0.3
>     +-org.apache.kafka:kafka_2.11:0.8.2.2
>       +-com.101tec:zkclient:0.3
> {code}
> I cannot emit a pull request without knowing on which specifics versions you rely.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message