flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steven Zhen Wu (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLINK-8043) change fullRestarts (for fine grained recovery) from guage to counter
Date Thu, 04 Jan 2018 01:28:00 GMT

    [ https://issues.apache.org/jira/browse/FLINK-8043?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16310567#comment-16310567
] 

Steven Zhen Wu commented on FLINK-8043:
---------------------------------------

[~trohrmann@apache.org] any objection/comment on changing this metric from guage to counter?

also metric naming seems inconsistent too. "fullRestarts" v.s. "task_failures".

> change fullRestarts (for fine grained recovery) from guage to counter
> ---------------------------------------------------------------------
>
>                 Key: FLINK-8043
>                 URL: https://issues.apache.org/jira/browse/FLINK-8043
>             Project: Flink
>          Issue Type: Bug
>          Components: ResourceManager
>    Affects Versions: 1.3.2
>            Reporter: Steven Zhen Wu
>
> Fine grained recovery publish fullRestarts as guage, which is not suitable for threshold
based alerting. Usually we would alert like "fullRestarts > 0 happens 10 times in last
15 minutes".
> In comparison, "task_failures" is published as counter.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message