flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLINK-8824) In Kafka Consumers, replace 'getCanonicalName()' with 'getClassName()'
Date Fri, 02 Mar 2018 12:38:00 GMT

    [ https://issues.apache.org/jira/browse/FLINK-8824?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16383539#comment-16383539

ASF GitHub Bot commented on FLINK-8824:

GitHub user zhangminglei opened a pull request:


    [FLINK-8824] [kafka] Replace getCanonicalName with getName

    ## What is the purpose of the change
    Since using ```getCanonicalName``` to get class name  there are potential problems. And
it is mainly for  normalizing class names for array.
    ## Brief change log
    Replace it with ```getName```

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/zhangminglei/flink flink-8824

Alternatively you can review and apply these changes as the patch at:


To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #5620
commit 634262b27b90cc1383c38ff8ac642f7aae522e71
Author: zhangminglei <zml13856086071@...>
Date:   2018-03-02T12:31:49Z

    [FLINK-8824] [kafka] Replace getCanonicalName with getName


> In Kafka Consumers, replace 'getCanonicalName()' with 'getClassName()'
> ----------------------------------------------------------------------
>                 Key: FLINK-8824
>                 URL: https://issues.apache.org/jira/browse/FLINK-8824
>             Project: Flink
>          Issue Type: Bug
>          Components: Kafka Connector
>            Reporter: Stephan Ewen
>            Assignee: mingleizhang
>            Priority: Major
>             Fix For: 1.5.0
> The connector uses {{getCanonicalName()}} inĀ all places, gather than {{getClassName()}}.
> {{getCanonicalName()}}'s intention is to normalize class names for arrays, etc, but is
problematic when instantiating classes from class names.

This message was sent by Atlassian JIRA

View raw message