flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "mingleizhang (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (FLINK-8835) Fix TaskManager config keys
Date Mon, 05 Mar 2018 09:41:00 GMT

    [ https://issues.apache.org/jira/browse/FLINK-8835?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16385857#comment-16385857
] 

mingleizhang edited comment on FLINK-8835 at 3/5/18 9:40 AM:
-------------------------------------------------------------

Hi, [~StephanEwen] I would like to confirm one stuff with you. I think we just rename the
key name is enough, but I found, Is it necessary to refactor the corresponding method and
variable name ? I do not think so. Because only the keys name exposes to *users* while method
and variable name only exposes to *developer*.

like the following, I just want to rename the key to {{taskmanager.registration.initial-backoff}},
instead rename the {{INITIAL_REGISTRATION_PAUSE}}.What do you think of that ? Thanks.
{code:java}
public static final ConfigOption<String> INITIAL_REGISTRATION_PAUSE =
		key("taskmanager.registration.initial-backoff")
			.defaultValue("500 ms")
{code}


was (Author: mingleizhang):
Hi, [~StephanEwen] I would like to confirm one stuff with you. I think we just rename the
key name is enough, but I found, Is it necessary to refactor the corresponding method and
variable name ? I do not think so. Because only the keys name exposes to users while method
and variable name only exposes to developer. 

like the following, I just want to rename the key to {{taskmanager.registration.initial-backoff}},
instead rename the {{INITIAL_REGISTRATION_PAUSE}}.What do you think of that ? Thanks.

{code:java}

public static final ConfigOption<String> INITIAL_REGISTRATION_PAUSE =
		key("taskmanager.registration.initial-backoff")
			.defaultValue("500 ms")
{code}


> Fix TaskManager config keys
> ---------------------------
>
>                 Key: FLINK-8835
>                 URL: https://issues.apache.org/jira/browse/FLINK-8835
>             Project: Flink
>          Issue Type: Bug
>          Components: TaskManager
>            Reporter: Stephan Ewen
>            Assignee: mingleizhang
>            Priority: Blocker
>              Labels: easy-fix
>             Fix For: 1.5.0
>
>
> Many new config keys in the TaskManager don't follow the proper naming scheme. We need
to clear those up before the release. I would also suggest to keep the key names short, because
that makes it easier for users.
> When doing this cleanup pass over the config keys, I would suggest to also make some
of the existing keys more hierarchical harmonize them with the common scheme in Flink.
> h1. New Keys
> * {{taskmanager.network.credit-based-flow-control.enabled}} to {{taskmanager.network.credit-model}}.
> * {{taskmanager.exactly-once.blocking.data.enabled}} to {{task.checkpoint.alignment.blocking}}
(we already have {{task.checkpoint.alignment.max-size}})
> h1. Existing Keys
> * {{taskmanager.debug.memory.startLogThread}} => {{taskmanager.debug.memory.log}}
> * {{taskmanager.debug.memory.logIntervalMs}} => {{taskmanager.debug.memory.log-interval}}
> * {{taskmanager.initial-registration-pause}} => {{taskmanager.registration.initial-backoff}}
> * {{taskmanager.max-registration-pause}} => {{taskmanager.registration.max-backoff}}
> * {{taskmanager.refused-registration-pause}} {{taskmanager.registration.refused-backoff}}
> * {{taskmanager.maxRegistrationDuration}} ==> * {{taskmanager.registration.timeout}}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message