flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ted Yu (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (FLINK-9150) Prepare for Java 10
Date Tue, 28 Aug 2018 03:30:00 GMT

    [ https://issues.apache.org/jira/browse/FLINK-9150?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16473198#comment-16473198
] 

Ted Yu edited comment on FLINK-9150 at 8/28/18 3:29 AM:
--------------------------------------------------------

Similar error is encountered when building against jdk 11.


was (Author: yuzhihong@gmail.com):
Similar error is encountered when building against jdk 11 .

> Prepare for Java 10
> -------------------
>
>                 Key: FLINK-9150
>                 URL: https://issues.apache.org/jira/browse/FLINK-9150
>             Project: Flink
>          Issue Type: Task
>          Components: Build System
>            Reporter: Ted Yu
>            Priority: Major
>
> Java 9 is not a LTS release.
> When compiling with Java 10, I see the following compilation error:
> {code}
> [ERROR] Failed to execute goal on project flink-shaded-hadoop2: Could not resolve dependencies
for project org.apache.flink:flink-shaded-hadoop2:jar:1.6-SNAPSHOT: Could not find artifact
jdk.tools:jdk.tools:jar:1.6 at specified path /a/jdk-10/../lib/tools.jar -> [Help 1]
> {code}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message