flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Florian (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (FLINK-10104) Job super slow to start
Date Mon, 13 Aug 2018 10:23:00 GMT

    [ https://issues.apache.org/jira/browse/FLINK-10104?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16577989#comment-16577989
] 

Florian edited comment on FLINK-10104 at 8/13/18 10:22 AM:
-----------------------------------------------------------

Hi [~gjy],

Thanks a lot for your time and your investigation.

I think you are right, we are running Hortonworks HDP 2.5

Unfortunately, I don't have more details on the problem, but it seems that it is working fine
with Flink 1.6.0. Just noticed it has been release so I wanted to give it a try, and it works
just fine.

 

However, I still have this strange issue saying that I am using version 0.1, now, with version
1.6.0 :

Starting YarnJobClusterEntrypoint (Version: 0.1, Rev:ff472b4, Date:07.08.2018 @ 15:31:13 CEST)

I also noticed that I already had this problem with 1.4.2:

Starting YARN ApplicationMaster / ResourceManager / JobManager (Version: 0.1, Rev:04e4c85,
Date:28.02.2018 @ 20:53:14 CST)


was (Author: fsimond):
Hi [~gjy],

Thanky a lot for your time and your investigation.

I think you are right, we are running Hortonworks HDP 2.5

Unfortunately, I don't have more details on the problem, but it seems that it is working fine
with Flink 1.6.0. Just noticed it has been release so I wanted to give it a try, and it works
just fine.

 

However, I still have this strange issue saying that I am using version 0.1, now, with version
1.6.0 :

Starting YarnJobClusterEntrypoint (Version: 0.1, Rev:ff472b4, Date:07.08.2018 @ 15:31:13 CEST)

I also noticed that I already had this problem with 1.4.2:

Starting YARN ApplicationMaster / ResourceManager / JobManager (Version: 0.1, Rev:04e4c85,
Date:28.02.2018 @ 20:53:14 CST)

> Job super slow to start
> -----------------------
>
>                 Key: FLINK-10104
>                 URL: https://issues.apache.org/jira/browse/FLINK-10104
>             Project: Flink
>          Issue Type: Bug
>    Affects Versions: 1.5.2
>            Reporter: Florian
>            Priority: Major
>         Attachments: flink2.log
>
>
> Following a discussion on another topic with [~GJL] ( [http://apache-flink-user-mailing-list-archive.2336050.n4.nabble.com/Could-not-build-the-program-from-JAR-file-td22102.html
)|http://apache-flink-user-mailing-list-archive.2336050.n4.nabble.com/Could-not-build-the-program-from-JAR-file-td22102.html]
> It seems that there is a bug as my job is very slow to start.
> I am using Flink to process messages from an input topic, and to redirect them to two
output topics, and when I start the job, I have to wait between 5 and 10 minutes before I
get anything into the output topic. With version 1.4.2, it was much faster.
> I run the job on Yarn, and, as asked by Gary, I attached the results of yarn logs -applicationId
<appId>
>  
> Also, as you can notice from the logs, the reported version is 0.1 Rev:1a9b648. I have
no clue why, as I downloaded the official Flink 1.5.2 distribution
>  
>  
>  
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message