flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Neelesh Srinivas Salian (JIRA)" <j...@apache.org>
Subject [jira] [Assigned] (FLINK-1890) Add note to docs that ReadFields annotations are currently not evaluated
Date Wed, 17 Apr 2019 17:15:00 GMT

     [ https://issues.apache.org/jira/browse/FLINK-1890?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Neelesh Srinivas Salian reassigned FLINK-1890:
----------------------------------------------

    Assignee:     (was: Neelesh Srinivas Salian)

> Add note to docs that ReadFields annotations are currently not evaluated
> ------------------------------------------------------------------------
>
>                 Key: FLINK-1890
>                 URL: https://issues.apache.org/jira/browse/FLINK-1890
>             Project: Flink
>          Issue Type: Wish
>          Components: API / DataSet
>            Reporter: Stefan Bunk
>            Priority: Minor
>              Labels: starter
>
> In the Scala API, you have the option to declare forwarded fields via the
> {{withForwardedFields}} method.
> It would be nice to have sth. similar for read fields, as otherwise one needs to create
a class, which I personally try to avoid for readability.
> Maybe grouping all annotations in one function and have a first parameter indicating
the type of annotation is also an option, if you plan on adding more annotations and want
to keep the interface smaller.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message