flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (FLINK-12516) Update Travis base image from trusty to xenial
Date Wed, 15 May 2019 11:32:00 GMT

     [ https://issues.apache.org/jira/browse/FLINK-12516?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

ASF GitHub Bot updated FLINK-12516:
-----------------------------------
    Labels: pull-request-available  (was: )

> Update Travis base image from trusty to xenial
> ----------------------------------------------
>
>                 Key: FLINK-12516
>                 URL: https://issues.apache.org/jira/browse/FLINK-12516
>             Project: Flink
>          Issue Type: Bug
>          Components: Travis
>    Affects Versions: 1.9.0
>            Reporter: Nico Kruber
>            Assignee: Nico Kruber
>            Priority: Major
>              Labels: pull-request-available
>             Fix For: 1.9.0
>
>
> Currently, our Travis tests are running with a {{trusty}} environment which is officially
not supported by Ubuntu anymore. It also brings old system libraries which blocks unit tests
for FLINK-11579.
> I propose to update to xenial (Ubuntu 16.04 LTS) which is still supported until 2021-04.
> Since Travis doesn't support oraclejdk8 on xenial, however, this also implies a switch
to openJDK 8.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message