flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "zhijiang (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (FLINK-12603) Refactor InputGate interface to remove unnecessary methods
Date Fri, 24 May 2019 06:50:00 GMT

     [ https://issues.apache.org/jira/browse/FLINK-12603?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

zhijiang updated FLINK-12603:
-----------------------------
    Summary: Refactor InputGate interface to remove unnecessary methods  (was: Remove getOwningTaskName
method from InputGate)

> Refactor InputGate interface to remove unnecessary methods
> ----------------------------------------------------------
>
>                 Key: FLINK-12603
>                 URL: https://issues.apache.org/jira/browse/FLINK-12603
>             Project: Flink
>          Issue Type: Sub-task
>          Components: Runtime / Network
>            Reporter: zhijiang
>            Assignee: zhijiang
>            Priority: Minor
>              Labels: pull-request-available
>          Time Spent: 10m
>  Remaining Estimate: 0h
>
> Current `InputGate#getOwningTaskName` is only used for logging in related components
such as `BarrierBuffer`, `StreamInputProcessor`, etc. We could put this name in the structure
of `TaskInfo`,  then the related components could get task name directly from `RuntimeEnvironment#getTaskInfo`.
> To do so, we could simplify the interface of `InputGate`.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message