flink-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From makeyang <riverbuild...@hotmail.com>
Subject managin order to use epoll (tasker.network.netty.transport: epoll), is it required that linux version is 4.0.16 or newer or not
Date Fri, 20 Apr 2018 13:35:41 GMT
my flink veriso is 1.4.2
my jdk version is 1.8.0.20
my linux version is:3.10.0

I try to use epoll with setting: tasker.network.netty.transport: epoll
but it throws excption which leads me here:
https://github.com/apache/flink-shaded/issues/30
I followed the instruction and still exception throws. 
then I found below link Native transports whic is offical netty doc below:
http://netty.io/wiki/native-transports.html
and it says:
Netty provides the following platform specific JNI transports:
    Linux (since 4.0.16)

so my question is:
in order to use this epoll,  is it required that linux version is 4.0.16 or
newer or not?





--
Sent from: http://apache-flink-user-mailing-list-archive.2336050.n4.nabble.com/

Mime
View raw message