gearpump-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Huafeng Wang (JIRA)" <>
Subject [jira] [Commented] (GEARPUMP-161) Application logs are not created on Yarn
Date Mon, 08 Aug 2016 08:29:20 GMT


Huafeng Wang commented on GEARPUMP-161:

I tried with the RC5 release and here is what I got.

There is no other log4j configuration files under *$CONTAINER_HOME/pack/gearpump-2.11-0.8.1-RC5/conf*
folder. Actually this folder should be exactly the same content as gearpump tar file that
uploaded previously.

My question here is how do you guys launch Gearpump on Yarn? Using TAP or just the way described
in Gearpump's README in Yarn module?

> Application logs are not created on Yarn 
> -----------------------------------------
>                 Key: GEARPUMP-161
>                 URL:
>             Project: Apache Gearpump
>          Issue Type: Bug
>          Components: yarn
>    Affects Versions: 0.8.0
>         Environment: yarn deployment: 1 master, 1 worker;
>            Reporter: Karol Brejna
>            Assignee: Huafeng Wang
> I have a simple cluster (1 master, 1 worker) running on YARN.
> I deploy an app. The app lands on a worker (cdh-worker-2 machine in this case).
> I inspect the worker and the app settings in the dashborad.
> Worker dir is shown as: /var/log/hadoop-yarn/container/application_1466296175601_0020/container_e05_1466296175601_0020_01_000003
> App log dir: /data1/hadoop/yarn/nm/usercache/cf/appcache/application_1466296175601_0020/container_e05_1466296175601_0020_01_000003/logs
> The logs are written to worker log dir under stderr.
> But there is no such a folder for app logs. 'logs' doesn exists under indicated location.
> I tried to do a wrokarounds (as I thought it may be a simple permissions issue):
> 1.
> chmod 777 on parent dir (/data1/hadoop/yarn/nm/usercache/cf/appcache/application_1466296175601_0020/container_e05_1466296175601_0020_01_000003)
> restarted app 
> No results here. logs dir not created.
> 2. 
> created logs dir by hand and changed permissions:
> mkdir logs
> chmod 777 logs
> No results here. logs dir not populated.

This message was sent by Atlassian JIRA

View raw message