geronimo-xbean-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Dillon <ja...@planet57.com>
Subject Re: XBean and Java 1.5 (was Re: Where is the src for org.apache.geronimo.gjndi.GlobalContextGBean)
Date Wed, 21 Mar 2007 18:20:55 GMT
Should not cause any build problems that I am aware of.  If anything  
does come up I will fix it ;-)

Either way... I don't really care... I want JDK 1.5 anyways, 1.4 and  
retro muck is just for any folks who consume xbean that can't use JDK  
1.5.

Shall I look into what changes are required?  Though I have commit  
here if you guys wanna see a patch first I can can make one...

--jason


On Mar 21, 2007, at 11:11 AM, David Jencks wrote:

> I'm fine (down?) with it as long as it doesn't create build  
> problems and I don't have to set it up.  I voted +0, not -0.
>
> thanks
> david jencks
>
> On Mar 21, 2007, at 1:47 PM, Jason Dillon wrote:
>
>> BTW, with the latest retrotranslator-maven-plugin, the translate- 
>> project goal makes translation and install/publish transparent,  
>> defaulting to using jdk14 for the classifier for the translated bits.
>>
>> I'm also not sure why folks are anti publishing these jars... they  
>> are there to support folks who are using JDK 1.4.  I suppose if  
>> users want they can retrotranslate themselves... but thats more  
>> work.  Perhaps if folks are still -1 on this, once people start to  
>> ask for this they will reconsider?  I dunno... seems harmless to  
>> retrotranslate them IMO.  Not like xbean has 200 modules like G does.
>>
>> --jason
>>
>>
>> On Mar 21, 2007, at 10:27 AM, Guillaume Nodet wrote:
>>
>>> Why are you both reluctant to publish retrotranslated jars ?
>>>
>>> On 3/21/07, Alan D. Cabrera <list@toolazydogs.com> wrote:
>>>>
>>>> -1 (not a veto but a cancelable vote) on publishing retro-jars.
>>>>
>>>>
>>>> Regards,
>>>> Alan
>>>>
>>>> On Mar 21, 2007, at 9:55 AM, David Jencks wrote:
>>>>
>>>> > +1 to 1.5 only
>>>> > +0 to publishing retro-jars
>>>> >
>>>> > david jencks
>>>> >
>>>> > On Mar 20, 2007, at 11:16 PM, Jason Dillon wrote:
>>>> >
>>>> >> Looks like xbean-naming is still compiling for 1.4.  Is there  
>>>> any
>>>> >> specific reason for this?  Can we switch all of xbean to compile
>>>> >> for 1.5... and if you need 1.4 compat, then use the
>>>> >> retrotranslator-maven-plugin's translate-project goal to make
>>>> >> jdk14 artifacts?
>>>> >>
>>>> >> --jason
>>>> >>
>>>> >>
>>>> >> On Mar 20, 2007, at 5:14 AM, David Jencks wrote:
>>>> >>
>>>> >>> geronimo-naming jar
>>>> >>>
>>>> >>> I think you'll find you need to update xbean-naming.
>>>> >>>
>>>> >>> thanks
>>>> >>> david jencks
>>>> >>> On Mar 20, 2007, at 4:03 AM, Jason Dillon wrote:
>>>> >>>
>>>> >>>> The server/trunk build is picking this up in configs/rmi-
>>>> >>>> naming... but from where?
>>>> >>>>
>>>> >>>> Need to update this to use java.util.concurrent... its using
>>>> >>>> backport-concurrent-util at the moment.
>>>> >>>>
>>>> >>>> --jason
>>>> >>>
>>>> >>
>>>> >
>>>> >
>>>>
>>>>
>>>
>>>
>>> -- 
>>> Cheers,
>>> Guillaume Nodet
>>> ------------------------
>>> Architect, LogicBlaze (http://www.logicblaze.com/)
>>> Blog: http://gnodet.blogspot.com/
>>
>


Mime
View raw message