geronimo-xbean-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From 梁宏鑫 <hxliang1...@gmail.com>
Subject Re: Not compatible with spring 3.0.x
Date Thu, 01 Jul 2010 00:37:47 GMT

No, not with trunk yet, but we tried latest version and it also did not work. Anyway, this
project seems not so active. Not sure whether there are  many people using it or not.

在 2010-7-1,7:33,Kevan Miller <kevan.miller@gmail.com> 写到:

> 
> On Jun 29, 2010, at 10:33 AM, Hongxin Liang wrote:
> 
>> We just upgrade to spring 3.0.3, but suddenly find that xbean-spring does
>> not work, as spring 3.0.x added schema validation by default which happens
>> in AbstractXmlApplicationContext.java:: initBeanDefinitionReader(). In
>> spring 2, this method is empty, while in 3.0.x, it is as following:
>> 
>> protected void initBeanDefinitionReader(XmlBeanDefinitionReader reader) {
>> 
>>   reader.setValidating(this.validating);
>> }
>> 
>> So we get trouble.
>> 
>> My question is, is there any plan to fix this in xbean-spring itself?
>> Or more general, to comply with spring 3. Although we can fix it by
>> overriding this method, we're looking forward to official solution.
> 
> I haven't heard of anybody talking about it, but it's a reasonable request.  Have you
tried building trunk with an updated version numbers for the spring dependencies?
> 
> --kevan

Mime
View raw message