gora-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ferdy Galema <ferdy.gal...@kalooga.com>
Subject Re: Jenkins build became unstable: gora-trunk » Apache Gora :: Hbase #206
Date Sun, 08 Apr 2012 16:15:17 GMT
The same to you!

Yeah it's good you updated the HBase issue. It certainly looks an issue
that needs to be solved in HadoopTestCase. For now it should not be in our
way.

On Sun, Apr 8, 2012 at 6:08 PM, Lewis John Mcgibbney <
lewis.mcgibbney@gmail.com> wrote:

> Hey Ferdy happy Easter.
>
> I also jumped on to one of the HBase Jira issues as we experience the exact
> same problems as they quote in the thread.
>
> https://issues.apache.org/jira/brownutchse/HBASE-4709<https://issues.apache.org/jira/browse/HBASE-4709>
>
> We'll wait and see what happens here.. I personally think it looks like a
> problem with the HadoopTestCase but maybe I am wrong. I've seen guys over @
> James and Pig experiencing similar problems as well.
>
>
> On Sun, Apr 8, 2012 at 5:04 PM, Ferdy Galema <ferdy.galema@kalooga.com
> >wrote:
>
> > Hi Lewis,
> >
> > Thanks for updating. The HBase (mapreduce) tests are very sensitive to
> > minor deviations from standard network configuration. For example I also
> > noticed that having a wrong hosts file entry can make the mini cluster
> > instances bind to different interfaces therefore unable to connect in
> > certain cases.
> >
> > Anyway, it's good to keep this in mind.
> >
> > On Sat, Apr 7, 2012 at 5:52 PM, Lewis John Mcgibbney <
> > lewis.mcgibbney@gmail.com> wrote:
> >
> > > Hi Ferdy,
> > >
> > > The reason my trunk builds hangs from home is that I'm using Tinyproxy,
> > > therefore I get stuff like
> > >
> > > [INFO] org.apache.hadoop.hbase.client.RetriesExhaustedException: Failed
> > > setting up proxy interface org.apache.hadoop.hbase.ipc.HRegionInterface
> > to
> > > /
> > > 127.0.0.1:44730 after attempts=1
> > > [INFO]     at
> > > org.apache.hadoop.hbase.ipc.HBaseRPC.waitForProxy(HBaseRPC.java:355)
> > > [INFO]     at
> > >
> > >
> >
> org.apache.hadoop.hbase.client.HConnectionManager$HConnectionImplementation.getHRegionConnection(HConnectionManager.java:969)
> > > [INFO]     at
> > >
> > >
> >
> org.apache.hadoop.hbase.master.ServerManager.getServerConnection(ServerManager.java:620)
> > > [INFO]     at
> > >
> > >
> >
> org.apache.hadoop.hbase.master.ServerManager.sendRegionOpen(ServerManager.java:555)
> > > [INFO]     at
> > >
> > >
> >
> org.apache.hadoop.hbase.master.AssignmentManager.assign(AssignmentManager.java:1043)
> > > [INFO]     at
> > >
> > >
> >
> org.apache.hadoop.hbase.master.AssignmentManager.assign(AssignmentManager.java:858)
> > > [INFO]     at
> > >
> > >
> >
> org.apache.hadoop.hbase.master.AssignmentManager.assign(AssignmentManager.java:838)
> > > [INFO]     at
> > >
> > >
> >
> org.apache.hadoop.hbase.master.AssignmentManager.assignRoot(AssignmentManager.java:1304)
> > > [INFO]     at
> > >
> >
> org.apache.hadoop.hbase.master.HMaster.assignRootAndMeta(HMaster.java:431)
> > > [INFO]     at
> > >
> > >
> >
> org.apache.hadoop.hbase.master.HMaster.finishInitialization(HMaster.java:388)
> > > [INFO]     at
> > org.apache.hadoop.hbase.master.HMaster.run(HMaster.java:282)
> > > [INFO]     at java.lang.Thread.run(Thread.java:679)
> > > [INFO] Caused by: java.net.ConnectException: Connection refused
> > > [INFO]     at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)
> > > [INFO]     at
> > > sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:592)
> > > [INFO]     at
> > >
> > >
> >
> org.apache.hadoop.net.SocketIOWithTimeout.connect(SocketIOWithTimeout.java:206)
> > > [INFO]     at org.apache.hadoop.net.NetUtils.connect(NetUtils.java:489)
> > > [INFO]     at
> > >
> > >
> >
> org.apache.hadoop.hbase.ipc.HBaseClient$Connection.setupIOstreams(HBaseClient.java:328)
> > > [INFO]     at
> > >
> >
> org.apache.hadoop.hbase.ipc.HBaseClient.getConnection(HBaseClient.java:883)
> > > [INFO]     at
> > > org.apache.hadoop.hbase.ipc.HBaseClient.call(HBaseClient.java:750)
> > > [INFO]     at
> > > org.apache.hadoop.hbase.ipc.HBaseRPC$Invoker.invoke(HBaseRPC.java:257)
> > > [INFO]     at $Proxy12.getProtocolVersion(Unknown Source)
> > > [INFO]     at
> > > org.apache.hadoop.hbase.ipc.HBaseRPC.getProxy(HBaseRPC.java:419)
> > > [INFO]     at
> > > org.apache.hadoop.hbase.ipc.HBaseRPC.getProxy(HBaseRPC.java:393)
> > > [INFO]     at
> > > org.apache.hadoop.hbase.ipc.HBaseRPC.getProxy(HBaseRPC.java:444)
> > > [INFO]     at
> > > org.apache.hadoop.hbase.ipc.HBaseRPC.waitForProxy(HBaseRPC.java:349)
> > > [INFO]     ... 11 more
> > > [INFO] 12/04/07 16:49:21 WARN master.AssignmentManager: Unable to find
> a
> > > viable location to assign region -ROOT-,,0.70236052
> > > [INFO] 12/04/07 16:50:40 INFO datanode.DataBlockScanner: Verification
> > > succeeded for blk_4664606737046063270_1003
> > >
> > >
> > > On Thu, Apr 5, 2012 at 5:42 PM, Lewis John Mcgibbney <
> > > lewis.mcgibbney@gmail.com> wrote:
> > >
> > > > Hi Ferdy,
> > > >
> > > > Yeah just to confirm. All that was wrong was the machine I was
> running
> > my
> > > > tests from. Maybe it had something to do with my JVM settings or
> > > something
> > > > I am not sure. But on a better machine my HBase module tests ran
> fine.
> > > >
> > > >
> > > > On Wed, Apr 4, 2012 at 1:08 PM, Ferdy Galema <
> ferdy.galema@kalooga.com
> > > >wrote:
> > > >
> > > >> Hi Lewis,
> > > >>
> > > >> I'm not sure what the problem with your Gora build is, but I hope
> this
> > > >> helps somewhat: Generally I don't have the problem of hanging builds
> > > when
> > > >> running "mvn clean test". And I just ran the tests in head and there
> > > does
> > > >> not seem to be a problem. Also test run without failures.
> > > >>
> > > >> Ferdy.
> > > >>
> > > >> On Tue, Apr 3, 2012 at 12:52 PM, Lewis John Mcgibbney <
> > > >> lewis.mcgibbney@gmail.com> wrote:
> > > >>
> > > >> > Hi Guys,
> > > >> >
> > > >> > I think HBase tests are quite literally all over the place just
> now.
> > > >> I'll
> > > >> > try to have a crack at them later this afternoon but it appears
> that
> > > >> quite
> > > >> > often there is some dodgy outcomes from running the test suite
> > against
> > > >> the
> > > >> > hbase module.
> > > >> >
> > > >> > I can also confirm that my Gora build appears to hang when I
build
> > > >> > locally... does anyone else experience this?
> > > >> >
> > > >> > Thanks
> > > >> >
> > > >> > Lewis
> > > >> >
> > > >> > On Tue, Apr 3, 2012 at 6:13 AM, Apache Jenkins Server <
> > > >> > jenkins@builds.apache.org> wrote:
> > > >> >
> > > >> > > See <
> > > >> > >
> > > >>
> > >
> https://builds.apache.org/job/gora-trunk/org.apache.gora$gora-hbase/206/
> > > >> > >
> > > >> > >
> > > >> > >
> > > >> >
> > > >> >
> > > >> > --
> > > >> > *Lewis*
> > > >> >
> > > >>
> > > >
> > > >
> > > >
> > > > --
> > > > *Lewis*
> > > >
> > > >
> > >
> > >
> > > --
> > > *Lewis*
> > >
> >
>
>
>
> --
> *Lewis*
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message