gora-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Henry Saputra <henry.sapu...@gmail.com>
Subject Re: Build failed in Jenkins: goraamazon_branch #136
Date Fri, 16 Nov 2012 17:40:56 GMT
Ah it is ok Lewis, didn't mean to rush you.

I was just wondering about it to make sure its not some regressions I
introduced.

Thanks a lot for looking into it :)

- Henry

On Friday, November 16, 2012, Lewis John Mcgibbney <
lewis.mcgibbney@gmail.com> wrote:
> This is also an excellent reminder to complete the wiki entry and this
> very subject... nice one Henry :0)
>
> On Fri, Nov 16, 2012 at 5:20 PM, Lewis John Mcgibbney
> <lewis.mcgibbney@gmail.com> wrote:
>> Hi Henry,
>>
>> I've been trying to narrow this down. It's to do with deploying the
>> snapshots to repository.apache.org.
>>
>> Basically this is what is happening.
>>
>> Currently the gora-core-0.3-SNAPSHOT-tests.jar [0] and accompanying
>> signatures are all dated Tue Jul 24 05:48:55 UTC 2012, e.g. they have
>> not been updated... as the WebServiceTestBase (I think) class is not
>> included in this older SNAPSHOT the build fails. There is no *problem*
>> with the code, this is purely a Maven logistical pain in the neck.
>> I've been trying to resolve it by deploying non-unique tests snapshot
>> for gora-core but I think there is a bug in the deploy plugin... as I
>> am only able to deploy unique snapshots...
>>
>> I'll keep working on this Henry
>>
>> Lewis
>>
>> [0]
https://repository.apache.org/content/repositories/snapshots/org/apache/gora/gora-core/0.3-SNAPSHOT/
>>
>> On Fri, Nov 16, 2012 at 4:59 PM, Henry Saputra <henry.saputra@gmail.com>
wrote:
>>> Hi Guys,
>>>
>>> I am still seeing the "cannot find symbol" error in the gora-dynamo
module
>>> when building from trunk.
>>>
>>> Is there a bug to trace this issue?
>>>
>>> - Henry
>>>
>>>
>>> On Wed, Oct 31, 2012 at 10:37 AM, Lewis John Mcgibbney <
>>> lewis.mcgibbney@gmail.com> wrote:
>>>
>>>> Hi Renato,
>>>>
>>>> Its OK. I can confirm that things work fine when I run locally as well.
>>>> The problem relates to the restructuring of the core modules and the
>>>> fact that the goraamazon build pulls the 0.3-SNAPSHOT dependency
>>>> (generated from trunk) which doesn't contain the new restructuring.
>>>>
>>>> You can see these errors here
>>>>
>>>>
>>>>
https://builds.apache.org/view/G-L/view/Gora/job/goraamazon_branch/136/org.apache.gora$gora-dynamodb/console
>>>>
>>>> Please check them out and we can either discuss here or offline to
>>>> confirm that they would be resolved once the changes are ported to
>>>> trunk.
>>>>
>>>> On Wed, Oct 31, 2012 at 5:27 PM, Renato MarroquĂ­n Mogrovejo
>>>> <renatoj.marroquin@gmail.com> wrote:
>>>> > Hi,
>>>> >
>>>> > I don't know what breaks things in here. I tested locally and it
worked
>>>> fine.
>>>> > Lewis I remember you talking about this a while ago, do you have any
>>>> > clue on this? Or a place where I could start digging? If anybody has
>>>> > an idea of where to start on digging please let me know.
>>>> > Thanks in advance!
>>>> >
>>>> >
>>>> > Renato M.
>>>> >
>>>> > 2012/10/31 Apache Jenkins Server <jenkins@builds.apache.org>:
>>>> >> See <https://builds.apache.org/job/goraamazon_branch/136/changes>
>>>> >>
>>>> >> Changes:
>>>> >>
>>>> >> [rmarroquin] Committing new patch for changes in the way exception
were
>>>> being handled.
>>>> >>
>>>> >> ------------------------------------------
>>>> >> [...truncated 19900 lines...]
>>>> >> [INFO] Installing <
>>>>
https://builds.apache.org/job/goraamazon_branch/ws/branches/goraamazon/gora-cassandra/pom.xml
>
>>>> to
>>>> /home/jenkins/jen--
> Lewis
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message