gora-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apostolis Giannakidis <ap.giannaki...@gmail.com>
Subject Re: Upgrade of Avro in Gora
Date Wed, 12 Jun 2013 03:09:54 GMT
Oracle NoSQL currently depends on the 1.6.3 version of Apache Avro. I am
not sure how to identify if 1.3.3 is fully compatible with the version
1.6.3.

Cheers,
Apostolis


On Tue, Jun 11, 2013 at 7:59 PM, Renato Marroquín Mogrovejo <
renatoj.marroquin@gmail.com> wrote:

> yeah it has but it is on the bonding with the community time;)
>
>
>
>
> 2013/6/11 Henry Saputra <henry.saputra@gmail.com>
>
> > +1 more and more dependencies on Avro upgrades in Gora.
> >
> > But, I believe GSoC has already started, right?
> >
> > - Henry
> >
> >
> > On Tue, Jun 11, 2013 at 11:28 AM, Renato Marroquín Mogrovejo <
> > renatoj.marroquin@gmail.com> wrote:
> >
> > > For sure mate! we have been letting this be for too long. We might
> > create a
> > > different branch and push this forward before we start getting more
> > > challenges for the GSoCers ;)
> > >
> > > Renato M.
> > > On Jun 11, 2013 10:22 AM, "Lewis John Mcgibbney" <
> > > lewis.mcgibbney@gmail.com>
> > > wrote:
> > >
> > > > Hi Apostolis,
> > > > We need to determine whether oracle depends upon Avro... if so what
> > > > version... then if it is currently compatible.
> > > > Lets try and sort that out first.
> > > > Lewis
> > > >
> > > > On Tuesday, June 11, 2013, Apostolis Giannakidis <
> > > ap.giannakidis@gmail.com
> > > > >
> > > > wrote:
> > > > > Yes,
> > > > > it is definitely something that needs to be addressed.
> > > > > Ι think that I can contribute to this as part of the GSoC project.
> > > > > Do you believe that this can be accomplished within the timeframe
> of
> > > the
> > > > project?
> > > > > Best regards,
> > > > > Apostolis
> > > > >
> > > > >
> > > > > On Tue, Jun 11, 2013 at 5:12 PM, Lewis John Mcgibbney <
> > > > lewis.mcgibbney@gmail.com> wrote:
> > > > >>
> > > > >> Hi,
> > > > >> Been thinking about the GSoC project.
> > > > >> I think we will most likely have to deal with the upgrade of
Avro
> > for
> > > > this. I really do not see Oracle NoSQL being fully compatible with
> Avro
> > > > 1.3.3.
> > > > >> Just a thought....
> > > > >> There is a patch contributed by Ed a while back which completely
> > > > upgrades Avro in Gora. I think the time is ripe to do this. Upgrade
> of
> > > > HBase API will also rely upon it as well.
> > > > >> Lewis
> > > > >>
> > > > >> --
> > > > >> Lewis
> > > > >>
> > > > >
> > > > >
> > > >
> > > > --
> > > > *Lewis*
> > > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message