gora-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Medinets (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (GORA-238) Empty ByteBuffer reads back incorrectly.
Date Tue, 04 Jun 2013 03:55:19 GMT

     [ https://issues.apache.org/jira/browse/GORA-238?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

David Medinets resolved GORA-238.
---------------------------------

    Resolution: Not A Problem

After digging in the code for awhile, I learned that the family values specified in the gora-accumulo-mapping.xml
file must be unique for each field. If someone can valid this observation as true, the gora-accumulo
module page can be updated.
                
> Empty ByteBuffer reads back incorrectly.
> ----------------------------------------
>
>                 Key: GORA-238
>                 URL: https://issues.apache.org/jira/browse/GORA-238
>             Project: Apache Gora
>          Issue Type: Bug
>          Components: gora-accumulo
>    Affects Versions: 0.4
>            Reporter: David Medinets
>            Priority: Minor
>
> My json is {"name": "seven", "type": "bytes"}. When I set the value as object.setSeven(ByteBuffer.allocate(10));
it is read back from Accumulo as "null". 

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message