gora-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kazuomi Kashii (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (GORA-278) Upgrade Cassandra to 2.x
Date Fri, 07 Feb 2014 17:11:21 GMT

     [ https://issues.apache.org/jira/browse/GORA-278?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Kazuomi Kashii updated GORA-278:
--------------------------------

    Attachment: GORA-278.patch

It requires the following dependencies in pom.xml :
* cassandra 2.0.4
* libthrift 0.9.1
* hector 1.1-4
* guava 15.0 (13.0 should be fine)

pom.xml of this patch breaks gora-hbase test because of guava dependency,
so gora-hbase is commented out for this patch.

The current gora-cassandra works with Cassandra 2.0.4 without any change,
but the following two files need to be updated for test.

* src/test/conf/cassandra.yaml

* src/test/java/org/apache/gora/cassandra/GoraCassandraTestDrive.java
because CassandraDaemon's package was changed from thrift to service.

This patch changes only three files.

> Upgrade Cassandra to 2.x
> ------------------------
>
>                 Key: GORA-278
>                 URL: https://issues.apache.org/jira/browse/GORA-278
>             Project: Apache Gora
>          Issue Type: Bug
>          Components: gora-cassandra
>            Reporter: Lewis John McGibbney
>             Fix For: 0.5
>
>         Attachments: GORA-278.patch
>
>
> Apart from the fact that 2.x was released some months ago, there are other nasty issues
like CASSANDRA-4097 which make working with new (1.7.X) Avro and older (1.1.X, 1.2.X) Cassandra
dependencies difficult. 
> This is something for the 0.5 drive :)



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message