hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Suresh Srinivas (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-6223) New improved FileSystem interface for those implementing new files systems.
Date Thu, 29 Oct 2009 08:00:59 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-6223?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12771318#action_12771318

Suresh Srinivas commented on HADOOP-6223:

# AFS - move static member variables to the beginning of the class
# AFS.FTP_SCHEME should move to FtpFS. AFS.LOCAL_FS_URI should move to RawLocalFs or some
constants file.
# AFS.isValidName - not sure why check for "/" is being done, given that tokenizer uses it
as separator?
# AFS statistics - file a jira to port FileSystem tests including statistics related tests
to test AFS.
# AFS.get() - remove check for null scheme since it is done in AbstractFileSystem constructor.
For authority, we could even have a flag needAuthority that can be passed by the implementations
to AbstractFileSystem constructor.
# AFS.getPathPart() is getUriPath a better name for this method?
# AFS.statistics should be protected or method AFS.getStatistics() should be protected for
subclasses to set stats. 
# Underlying FileSystem.statistics should be same as AFS.statistics.
# FilterFs.getUriDefaultPort() should delegate the call to underlying AFS. With this LocalFs
need not override this method.
# FilterFs.myFs should this or getMyFs() be protected to allow subclass to access it.

> New improved FileSystem interface for those implementing new files systems.
> ---------------------------------------------------------------------------
>                 Key: HADOOP-6223
>                 URL: https://issues.apache.org/jira/browse/HADOOP-6223
>             Project: Hadoop Common
>          Issue Type: Sub-task
>            Reporter: Sanjay Radia
>            Assignee: Sanjay Radia
>         Attachments: AbstractFileSystem.java, afs1.patch, AFS10.patch, AFS11.patch, AFS15.patch,
AFS16.patch, AFS4.patch, Hdfs.java, Hdfs.java
> The FileContext API (HADOOP-4952) provides an improved interface for the application
> This lets us simplify the FileSystem API since it will no longer need to deal with notions
of default filesystem [ / ],  wd, and config
> defaults for blocksize, replication factor etc. Further it will not need the many overloaded
methods for create() and open() since
> the FileContext API provides that convenience.
> The FileSystem API can be simplified and can now be restricted to those implementing
new file systems.
> This jira proposes that we create new file system API,  and deprecate FileSystem API
after a few releases.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message