hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hairong Kuang (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-7058) Expose number of bytes in FSOutputSummer buffer to implementatins
Date Tue, 07 Dec 2010 15:03:11 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-7058?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12968769#action_12968769

Hairong Kuang commented on HADOOP-7058:

Could you please rename the method name to be something like getBufferedDataSize? The data
in the buffer may have already be flushed. So your name is confusing.

> Expose number of bytes in FSOutputSummer buffer to implementatins
> -----------------------------------------------------------------
>                 Key: HADOOP-7058
>                 URL: https://issues.apache.org/jira/browse/HADOOP-7058
>             Project: Hadoop Common
>          Issue Type: Improvement
>    Affects Versions: 0.22.0, 0.23.0
>            Reporter: Todd Lipcon
>            Assignee: Todd Lipcon
>            Priority: Trivial
>         Attachments: hadoop-7058.txt
> For HDFS-1497 it would be useful for an FSOutputSummer implementation to know how many
bytes are in the FSOutputSummer buffer. This trivial patch adds a protected call to return

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message