hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-7059) Remove "unused" warning in native code
Date Tue, 07 Dec 2010 22:51:10 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-7059?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12969060#action_12969060

Hadoop QA commented on HADOOP-7059:

-1 overall.  Here are the results of testing the latest attachment 
  against trunk revision 1043117.

    +1 @author.  The patch does not contain any @author tags.

    -1 tests included.  The patch doesn't appear to include any new or modified tests.
                        Please justify why no new tests are needed for this patch.
                        Also please list what manual steps were performed to verify this patch.

    +1 javadoc.  The javadoc tool did not generate any warning messages.

    +1 javac.  The applied patch does not increase the total number of javac compiler warnings.

    +1 findbugs.  The patch does not introduce any new Findbugs (version 1.3.9) warnings.

    +1 release audit.  The applied patch does not increase the total number of release audit

    +1 core tests.  The patch passed core unit tests.

    +1 contrib tests.  The patch passed contrib unit tests.

    +1 system test framework.  The patch passed system test framework compile.

Test results: https://hudson.apache.org/hudson/job/PreCommit-HADOOP-Build/135//testReport/
Findbugs warnings: https://hudson.apache.org/hudson/job/PreCommit-HADOOP-Build/135//artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
Console output: https://hudson.apache.org/hudson/job/PreCommit-HADOOP-Build/135//console

This message is automatically generated.

> Remove "unused" warning in native code
> --------------------------------------
>                 Key: HADOOP-7059
>                 URL: https://issues.apache.org/jira/browse/HADOOP-7059
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: native
>    Affects Versions: 0.21.0
>            Reporter: Noah Watkins
>         Attachments: HADOOP-7059-1.patch
> The file:
>    src/native/src/org_apache_hadoop.h
> declares the static function "do_dlsym" in the header as non-inline. Files including
the header (e.g. for the THROW macro) receive a "defined but unused" warning during compilation.
> This function should either a) be inlined or b) use GCC "unused" attribute.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message