hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aaron T. Myers (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-9173) Add security token related to protobuf definition to hadoop-common
Date Thu, 03 Jan 2013 01:56:12 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-9173?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13542652#comment-13542652

Aaron T. Myers commented on HADOOP-9173:

This patch looks fine to me, except that I think you can also replace the DelegationTokenProto
in yarn_protos.proto with this new refactored TokenProto.

Unless I'm missing the pattern, it seems we're pretty inconsistent about capitalizing the
.proto files throughout the project. Did you consciously choose to capitalize the name of
the file? If not, I'd recommend making it lower case, but I don't feel strongly about it.

I don't think you actually need to split this patch up into smaller ones. The change is straightforward,
and it seems better to me to keep it as one, since it is logically a single refactor.
> Add security token related to protobuf definition to hadoop-common
> ------------------------------------------------------------------
>                 Key: HADOOP-9173
>                 URL: https://issues.apache.org/jira/browse/HADOOP-9173
>             Project: Hadoop Common
>          Issue Type: Bug
>    Affects Versions: 2.0.2-alpha
>            Reporter: Suresh Srinivas
>            Assignee: Suresh Srinivas
>         Attachments: HADOOP-9173.patch, HADOOP-9173.patch
> The same definition is repeated across HDFS, MR and YARN. We could use the protobuf definitions.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message