hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Akira AJISAKA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-9913) Document time unit to RpcMetrics.java
Date Tue, 19 Aug 2014 07:25:18 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-9913?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14101964#comment-14101964

Akira AJISAKA commented on HADOOP-9913:

bq. Wouldn't this be better as documentation?
Now we have the [documentation|http://hadoop.apache.org/docs/r2.5.0/hadoop-project-dist/hadoop-common/Metrics.html]
which describes the time unit of the metrics, so the priority is very low.
bq. this is an incompatible change?
I don't think this is an incompatible change. [Compatibility doc|http://hadoop.apache.org/docs/current/hadoop-project-dist/hadoop-common/Compatibility.html#MetricsJMX]
Modifying (eg changing the unit or measurement) or removing existing metrics breaks compatibility.
Similarly, changes to JMX MBean object names also break compatibility.
The patch does not modify the unit, the measurement, or the object names. It only modifies
the description.

> Document time unit to RpcMetrics.java
> -------------------------------------
>                 Key: HADOOP-9913
>                 URL: https://issues.apache.org/jira/browse/HADOOP-9913
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: documentation, metrics
>    Affects Versions: 3.0.0, 2.1.0-beta
>         Environment: trunk
>            Reporter: Akira AJISAKA
>            Assignee: Akira AJISAKA
>            Priority: Minor
>              Labels: newbie
>         Attachments: HADOOP-9913.2.patch, HADOOP-9913.3.patch, HADOOP-9913.patch
> In o.a.h.ipc.metrics.RpcMetrics.java, metrics are declared as follows:
> {code}
>    @Metric("Queue time") MutableRate rpcQueueTime;
>    @Metric("Processsing time") MutableRate rpcProcessingTime;
> {code}
> Since some users may confuse which unit (sec or msec) is correct, they should be documented.

This message was sent by Atlassian JIRA

View raw message