hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joe Pallas (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-9279) Document the need to build hadoop-maven-plugins for eclipse and separate project builds
Date Tue, 10 Feb 2015 00:05:34 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-9279?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14313203#comment-14313203
] 

Joe Pallas commented on HADOOP-9279:
------------------------------------

Is the current documentation still misleading?  It seems that doing a top-level {{mvn compile}}
starting with an empty local repository will fail; and a {{mvn install}} that includes {{hadoop-maven-plugins}}
*must* be done first.

> Document the need to build hadoop-maven-plugins for eclipse and separate project builds
> ---------------------------------------------------------------------------------------
>
>                 Key: HADOOP-9279
>                 URL: https://issues.apache.org/jira/browse/HADOOP-9279
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: build, documentation
>    Affects Versions: 3.0.0
>         Environment: hadoop-maven-plugins-3.0.0-SNAPSHOT.jar doesn't exist in local repository
or at maven central repository.
>            Reporter: Tsuyoshi OZAWA
>            Assignee: Tsuyoshi OZAWA
>             Fix For: 2.1.0-beta
>
>         Attachments: HADOOP-9279.2.patch, HADOOP-9279.3.patch, HADOOP-9279.patch
>
>
> In current hadoop-trunk, compile fails when hadoop-maven-plugins-3.0.0-SNAPSHOT.jar doesn't
exist in local repository or at maven central repository.
> The affected components are:
> ./hadoop-common-project/hadoop-common/pom.xml
> ./hadoop-maven-plugins/pom.xml
> ./hadoop-project/pom.xml
> ./hadoop-yarn-project/hadoop-yarn/hadoop-yarn-common/pom.xml
> The error log is as follows
> {quote}
> [ERROR] Plugin org.apache.hadoop.maven.plugin:hadoop-maven-plugins:1.0 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for org.apache.hadoop.maven.plugin:hadoop-maven-plugins:jar:1.0:
Could not find artifact org.apache.hadoop.maven.plugin:hadoop-maven-plugins:pom:1.0 in central
(http://repo.maven.apache.org/maven2) -> [Help 1]
> {quote}
> This can be avoidable if hadoop-maven-plugins is installed before packaging. This is
undocumented, so this should get documented.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message