hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Nauroth (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-9565) Add a Blobstore interface to add to blobstore FileSystems
Date Tue, 03 Feb 2015 20:40:38 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-9565?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14303938#comment-14303938
] 

Chris Nauroth commented on HADOOP-9565:
---------------------------------------

Thanks for the detailed response, Steve.

I have found myself wanting the Java set API (not just {{EnumSet}}) to make it easier to chain
operations.

I have no objection to using the extra {{ObjectStore}} layer now and considering promotion
up to {{FileSystem}} later.  However, this does get a bit more involved on the {{FileContext}}
side.  I suppose it means we'd need:
# {{ObjectStoreAbstractFileSystem}} for implementors to extend.
# {{ObjectStoreFileContext}} used as a return value from {{FileContext#getFileContext}} and
queried for semantics by callers.
# {{ObjectStoreDelegateToFileSystem}} so that implementors still have the convenience of {{DelegateToFileSystem}}
as a simple passthrough after they have a working {{FileSystem}} subclass.

> Add a Blobstore interface to add to blobstore FileSystems
> ---------------------------------------------------------
>
>                 Key: HADOOP-9565
>                 URL: https://issues.apache.org/jira/browse/HADOOP-9565
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: fs, fs/s3, fs/swift
>    Affects Versions: 2.6.0
>            Reporter: Steve Loughran
>            Assignee: Steve Loughran
>         Attachments: HADOOP-9565-001.patch, HADOOP-9565-002.patch, HADOOP-9565-003.patch
>
>
> We can make the fact that some {{FileSystem}} implementations are really blobstores,
with different atomicity and consistency guarantees, by adding a {{Blobstore}} interface to
add to them. 
> This could also be a place to add a {{Copy(Path,Path)}} method, assuming that all blobstores
implement at server-side copy operation as a substitute for rename.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message