hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Nauroth (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HADOOP-9489) Eclipse instructions in BUILDING.txt don't work
Date Sun, 01 Mar 2015 18:57:05 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-9489?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Chris Nauroth updated HADOOP-9489:
    Attachment: HADOOP-9489.003.patch

Thanks for the reviews.  I'm attaching patch v003 with the changed hyperlink as suggested
by Tsuyoshi.

[~revans2], you had some earlier comments about this patch:


Do you object to committing this patch?  It sounds like some people have found it useful to
apply locally in their environments.

I'm not a regular Eclipse user, so I'm going to defer to other community members' judgment
on this.

> Eclipse instructions in BUILDING.txt don't work
> -----------------------------------------------
>                 Key: HADOOP-9489
>                 URL: https://issues.apache.org/jira/browse/HADOOP-9489
>             Project: Hadoop Common
>          Issue Type: Bug
>          Components: build
>    Affects Versions: 2.7.0
>            Reporter: Carl Steinbach
>            Assignee: Chris Nauroth
>            Priority: Minor
>         Attachments: HADOOP-9489.003.patch, HADOOP-9489.1.patch, HADOOP-9489.2.patch,
eclipse_hadoop_errors.txt, error.log
> I have tried several times to import Hadoop trunk into Eclipse following the instructions
in the BUILDING.txt file, but so far have not been able to get it to work.
> If I use a fresh install of Eclipse 4.2.2, Eclipse will complain about an undefined M2_REPO
environment variable. I discovered that this is defined automatically by the M2Eclipse plugin,
and think that the BUILDING.txt doc should be updated to explain this.
> After installing M2Eclipse I tried importing the code again, and now get over 2500 errors
related to missing class dependencies. Many of these errors correspond to missing classes
in the oah*.proto namespace, which makes me think that 'mvn eclipse:eclipse' is not triggering

This message was sent by Atlassian JIRA

View raw message