hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chengbing Liu (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-9489) Eclipse instructions in BUILDING.txt don't work
Date Mon, 02 Mar 2015 05:13:06 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-9489?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14342756#comment-14342756

Chengbing Liu commented on HADOOP-9489:

[~cnauroth] The following description
m2eclipse didn't know how to handle the goals in our custom Maven plugin for calling protoc
and generating version info. I updated the top-level pom.xml to run the protoc goal during
an Eclipse build and ignore the version-info goal. This eliminated nearly all of the remaining
~60 errors.
is not a problem any more. So I think we can just remove the change made to {base_dir}/pom.xml,
keep the rest of it, and test again.

> Eclipse instructions in BUILDING.txt don't work
> -----------------------------------------------
>                 Key: HADOOP-9489
>                 URL: https://issues.apache.org/jira/browse/HADOOP-9489
>             Project: Hadoop Common
>          Issue Type: Bug
>          Components: build
>    Affects Versions: 2.7.0
>            Reporter: Carl Steinbach
>            Priority: Minor
>         Attachments: HADOOP-9489.003.patch, HADOOP-9489.1.patch, HADOOP-9489.2.patch,
eclipse_hadoop_errors.txt, error.log
> I have tried several times to import Hadoop trunk into Eclipse following the instructions
in the BUILDING.txt file, but so far have not been able to get it to work.
> If I use a fresh install of Eclipse 4.2.2, Eclipse will complain about an undefined M2_REPO
environment variable. I discovered that this is defined automatically by the M2Eclipse plugin,
and think that the BUILDING.txt doc should be updated to explain this.
> After installing M2Eclipse I tried importing the code again, and now get over 2500 errors
related to missing class dependencies. Many of these errors correspond to missing classes
in the oah*.proto namespace, which makes me think that 'mvn eclipse:eclipse' is not triggering

This message was sent by Atlassian JIRA

View raw message