hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Colin Patrick McCabe (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-9805) Refactor RawLocalFileSystem#rename for improved testability.
Date Wed, 01 Apr 2015 21:24:54 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-9805?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14391495#comment-14391495

Colin Patrick McCabe commented on HADOOP-9805:

Looks good.

How about changing "renamePOSIX" to be named "handleEmptyDstDirectoryOnWindows"?

"renamePOSIX" sounds like something that should be called on POSIX platforms, not on Windows.
 Also, it doesn't suggest that its use case is handling empty destination directories.

> Refactor RawLocalFileSystem#rename for improved testability.
> ------------------------------------------------------------
>                 Key: HADOOP-9805
>                 URL: https://issues.apache.org/jira/browse/HADOOP-9805
>             Project: Hadoop Common
>          Issue Type: Bug
>          Components: fs, test
>    Affects Versions: 3.0.0, 1-win, 1.3.0, 2.1.1-beta
>            Reporter: Chris Nauroth
>            Assignee: Jean-Pierre Matsumoto
>            Priority: Minor
>              Labels: newbie
>         Attachments: HADOOP-9805.001.patch, HADOOP-9805.002.patch
> {{RawLocalFileSystem#rename}} contains fallback logic to provide POSIX rename behavior
on platforms where {{java.io.File#renameTo}} fails.  The method returns early if {{java.io.File#renameTo}}
succeeds, so test runs may not cover the fallback logic depending on the platform.

This message was sent by Atlassian JIRA

View raw message