hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kai Zheng (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-11740) Combine erasure encoder and decoder interfaces
Date Fri, 03 Apr 2015 00:37:53 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-11740?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14393815#comment-14393815

Kai Zheng commented on HADOOP-11740:

Thanks for the update. I looked the new patch, just two minor comments:
1. In the test codes, may be better to use {{ErasureCoder}} instead of {{AbstractErasureEncoder}}
or {{AbstractErasureDecoder}} since the interface type is good enough, which is why we're
here. With this refining, from caller's point of view, nothing different from between encoder
and decoder, so it should use the common interface.
2. Those unnecessary Javadoc are there to conform Javadoc conventions and format. In future
someone may fill them. I suggest we don't remove them, you can find so many in the project.

> Combine erasure encoder and decoder interfaces
> ----------------------------------------------
>                 Key: HADOOP-11740
>                 URL: https://issues.apache.org/jira/browse/HADOOP-11740
>             Project: Hadoop Common
>          Issue Type: Sub-task
>          Components: io
>            Reporter: Zhe Zhang
>            Assignee: Zhe Zhang
>         Attachments: HADOOP-11740-000.patch, HADOOP-11740-001.patch
> Rationale [discussed | https://issues.apache.org/jira/browse/HDFS-7337?focusedCommentId=14376540&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-14376540]
under HDFS-7337.

This message was sent by Atlassian JIRA

View raw message